Results 1 to 4 of 4

Thread: Compiled fixes that you might need.

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Posts
    74

    Default Compiled fixes that you might need.

    Now remember you have to be able to save changes for all of this to help;

    I have taken the time to compile some fixes that seem to be asked. I hope this helps.
    I have also tried to make it easy to understand for you that are just starting out , like I am.
    I have made step by step commands, so hopefully your time with BackTrack is much more fun.
    The forum here to me has been a life saver. All the things below have come from this very forum, so they get all the Credit.
    Enjoy!!


    If your having internet connection problems with an ath0 card this helped me

    Copy this to a terminal
    wget 'http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz'
    tar zxvf madwifi-ng-r2756+ar5007.tar.gz
    cd madwifi-ng-r2756+ar5007
    (Hit enter)

    After it downloads
    Type: make clean (hit enter)
    Type: make (hit enter)
    Type:make install (hit enter)
    Type:reboot (hit enter)


    To fix your sound if it does not work
    1-Copy Below
    2-open a terminal and Paste

    wget ftp://ftp.alsa-project.org/pub/drive...1.0.15.tar.bz2
    tar xvpjf alsa-driver-1.0.15.tar.bz2
    cd alsa-driver-1.0.15
    ./configure --with-cards=hda-intel
    (Hit Enter)

    Type: make (hit enter)
    Type:sudo make install (hit enter)
    You might have to reboot


    This is an auto update that works excellent: This also Fixes Slaptget
    1-Copy below
    2- open KWrite
    3- Right click in KWrite and Paste
    4 -Type: update (in the box)
    2-Open a termanal
    3-Type: chmod 755 update (hit enter)
    4-Type:update (hit enter)


    #!/bin/sh
    #
    #### Metasploit Framework 2/3,Aircrack-ng,Sqlite,Aircrack-ng -dev,Kismet,Slaptget,Wlassistant ####
    #
    option=13
    while [ $option -ne 0 ]
    do
    clear
    echo " 1. --> Update Metasploit Framework 3"
    echo " 2. --> Update Metasploit Framework 2"
    echo " 3. --> Update Aircrack-ng (0.9.1)"
    echo " 4. --> Update Kismet"
    echo " 5. --> Install Slaptget (0.9.12-i386-1)"
    echo " 6. --> Update Wireless Assistant (0.5.7)"
    echo " 7. --> Install Gpsd (2.34)"
    echo " 8. --> Install Sqlite (3.4.0) (Required, to allow use of Aircrack-ng dev)"
    echo " 9. --> Install Aircrack-ng dev"
    echo "10. --> Install Sqlite (3.4.0) and Aircrack-ng dev"
    echo "11. --> Update Airpwn (1.3)"
    echo "12. --> Update OpenSSL (0.9.8d) "
    echo " 0. --> Exit"
    read option
    case $option in
    #### This part was written by ReL1K ####
    1) echo "*** Updating Metasploit Framework 3 ***"
    svn update /pentest/exploits/framework3/;;
    2) echo "*** Updating Metasploit Framework 2 ***"
    svn update /pentest/exploits/framework2/;;
    #### This part was me with help from PrairieFire & purehate ####
    3) echo "UpDating Aircrack-ng..."
    wget http://download.aircrack-ng.org/airc...g-0.9.1.tar.gz
    tar -xf aircrack-ng-0.9.1.tar.gz
    cd aircrack-ng-0.9.1
    make clean && make && make install
    cd ..
    rm -r aircrack-ng-0.9.1
    rm -r aircrack-ng-0.9.1.tar.gz;;
    4) echo "UpDating Kismet..."
    svn co http://svn.kismetwireless.net/code/trunk kismet-devel
    cd kismet-devel
    ./configure --disable-setuid
    make dep && make && make install
    cd ..
    rm -r kismet-2007-01-R1b.tar.gz
    rm -r kismet-2007-01-R1b;;
    5) echo "Installing Slaptget"
    wget http://software.jaos.org/slackpacks/....12-i386-1.tgz
    installpkg slapt-get-0.9.12-i386-1.tgz
    rm -r slapt-get-0.9.12-i386-1.tgz
    echo "usage slapt-get --update"
    echo "slapt-get --upgrade";;
    6) echo "UpDating Wireless Assistant"
    wget http://downloads.sourceforge.net/wla...-0.5.7.tar.bz2
    tar -xvjf wlassistant-0.5.7.tar.bz2
    cd wlassistant-0.5.7
    ./configure && make clean && make && make install
    cd
    rm -r wlassistant-0.5.7
    rm -r wlassistant-0.5.7.tar.bz2;;
    7) wget http://download.berlios.de/gpsd/gpsd-2.34.tar.gz
    tar -xf gpsd-2.34.tar.gz
    cd gpsd-2.34
    ./configure && make clean && make && make install
    cd
    rm -r gpsd-2.34.tar.gz
    rm -r gpsd-2.34;;
    #### This part was balding_parrot ####
    8) echo "Installing Sqlite-3.4.0"
    cd /usr/local/bin
    ln -s tclsh8.4 tclsh
    cd /root
    curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
    tar xvzf sqlite-3.4.0.tar.gz
    cd sqlite-3.4.0
    ./configure --prefix=/usr/local
    make && make install
    cd ..
    rm -r sqlite-3.4.0
    rm -r sqlite-3.4.0.tar.gz;;
    9) echo "Install Aircrack-ng dev"
    svn co http://trac.aircrack-ng.org/svn/branch/1.0-dev aircrack-ng
    cd aircrack-ng
    gmake SQLITE=true
    gmake SQLITE=true install
    cd ..
    rm -r aircrack-ng;;
    10) echo "Installing Sqlite-3.4.0 and Aircrack-ng dev"
    cd /usr/local/bin
    ln -s tclsh8.4 tclsh
    cd /root
    curl -O http://www.sqlite.org/sqlite-3.4.0.tar.gz
    tar xvzf sqlite-3.4.0.tar.gz
    cd sqlite-3.4.0
    ./configure --prefix=/usr/local
    make && make install
    cd ..
    rm -r sqlite-3.4.0
    rm -r sqlite-3.4.0.tar.gz
    svn co http://trac.aircrack-ng.org/svn/branch/1.0-dev aircrack-ng
    cd aircrack-ng
    gmake SQLITE=true
    gmake SQLITE=true install
    cd
    rm -r aircrack-ng;;
    #### PrairieFire ####
    11) echo "Updating Airpwn..."
    wget http://kent.dl.sourceforge.net/sourc...airpwn-1.3.tgz
    gzip -d airpwn-1.3.tgz
    tar -xvvf airpwn-1.3.tar
    cd airpwn-1.3
    gzip -d lorcon-current.tgz
    tar -xvvf lorcon-current.tar
    cd lorcon
    ./configure && make && make install
    cd ..
    ./configure && make
    cd
    rm -r airpwn-1.3.tar
    rm -r airpwn-1.3;;
    12) echo "Updating Openssl..."
    curl -O http://openssl.org/source/openssl-0.9.8e.tar.gz
    tar -xvzf openssl-0.9.8e.tar.gz
    cd openssl-0.9.8e
    ./configure && make && make test && make install
    cd
    rm -r openssl-0.9.8e.tar.gz
    rm -r openssl-0.9.8e;;
    0) echo "*** Exiting ***"
    ;;
    *) exit &;;
    esac
    done


    Fix Kismet
    Open a terminal window and edit: /usr/local/etc/kismet.conf

    (you can use whatever editor you want: vi, kwrite, etc)

    Find the line:
    source=none,none,addone
    and replace it with:
    source=madwifi_ag,wifi0,madwifi
    *Note wif0 is for ath0, put whatever card you have there.

    Save kismet.conf (ctrl+x in nano). You will now need to start kismet from the terminal (rather than the K / Backtrack menu) by typing:
    kismet


    Purhates Video for making a USB **EXCELLENT**
    http://uploads.blip.tv/file/594903


    This forum has been excellent to me so I compiled some of the fixes i did.
    I want to help with what i can to give back. I hope this will help some of you.

    I will add more as I can think of them.

  2. #2
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    aircrack-ng-0.9.1.tar.gz
    kismet-2007-01-R1b.tar.gz
    wlassistant-0.5.7.tar.bz2
    gpsd-2.34.tar.gz
    sqlite-3.4.0.tar.gz
    openssl-0.9.8e.tar.gz
    software.jaos.org/slackpacks/11.0/slapt-get-0.9.12-i386-1.tgz
    These all need to be updated to current versions
    Μολὼν λαβέ - Great spirits encounter heavy opposition from mediocre minds.

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Posts
    74

    Default Thanks

    If anybody can add something to make this better for all, please do.
    If someone can update these, that know how, I would appreciate it also. Thank You!!

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Fasttrack will update a lot of those things to the current version. Kismet has its own svn update script in the /pentest/svn directory. There is no need to update wireless ass. because it sucks and I don't forsee it getting much better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •