Results 1 to 3 of 3

Thread: Goorecon and ruby

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    1

    Default Goorecon and ruby

    I was trying to use the tool goorecon and I get the error


    Code:
    bash: ./goorecon.rb: /usr/bin/ruby^M: bad interpreter: No such file or directory

    So I checked /usr/bin and ruby is there

    Code:
    root@bt:/pentest/enumeration/goorecon# ls -al /usr/bin | grep ruby
    lrwxrwxrwx  1 root   root           7 Jan 22 11:57 ruby -> ruby1.8
    -rwxr-xr-x  1 root   root        6320 Sep 26  2008 ruby-glade-create-template
    -rwxrwxrwx  1 root   root        5432 Jul 16  2009 ruby1.8

    other .rb work just fine.

    suggestions?

  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: Goorecon and ruby

    This is a bug. Thanks for finding and reporting it. See the fix here:
    http://www.backtrack-linux.org/forum....html#post2862

  3. #3
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default Re: Goorecon and ruby

    Thank you for the report.

    I have just uploaded a revised darkoperator-scripts package with the fixed goorecon.rb file to our svn, expect the new package to hit the repo in a few days.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •