Results 1 to 3 of 3

Thread: compiling rt73 drivers

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default compiling rt73 drivers

    Hi there,
    first off, thanks everyone for such a bloody good distro

    When searching for rt73 drivers i came across this walkthrough

    *ttp://garrettreid.com/wp-content/gallery/installing-rt73-drivers-in-backtrack/
    (sorry cant link)
    When i try to compile the drivers (make) i get the following error:
    Code:
    make: *** /lib/modules/2.6.20-BT-PwnSauce-NOSMP/build: No such file or directory.  Stop.
    rt73.ko failed to build!
    i dont really understand why! the directory exists!?

    Hope someone can point me in the right direction,
    Thank you

  2. #2
    Just burned his ISO
    Join Date
    Feb 2008
    Posts
    10

    Default

    This looks to be from unbuntu. I suggest no one try this --pureh@te

    first try

    cd /Module

    make clean
    make
    sudo make install

    sudo modprobe rt73


    then:
    (note: change **-->tt in: h**p)
    1) Install:
    sudo apt-get install build-essential linux-headers-`uname -r`
    2)Download:
    sudo wget h**p://rt2×00.serialmonkey.com/rt73-cvs-daily.tar.gz
    3) Unpack the previous tar.gz ("home" would be perfect)
    3) Change to the following directory:
    cd /rt73-cvs-yyyymmddhh/Module (based on where you unpacked it)
    4) Make:
    sudo make
    Just ignore the message:
    !!! WARNING: Module file much too big (>1MB)
    !!! Check your kernel settings or use ’strip’
    5) sudo strip -S rt73.ko
    6) sudo make install
    7) Get rid off network manager:
    sudo aptitude purge network-manager
    8)May or may not be necessary, to ease things??????
    sudo apt-get install rutilt
    9) Turn off the wlan0 for a while:
    sudo ifconfig wlan0 down
    10) Remove the following troublemakers:
    sudo modprobe -r rt73usb
    sudo modprobe -r rt2570
    sudo modprobe -r rt2500usb
    sudo modprobe -r rt2×00lib
    11) Blacklist the above, this is a must, as pointed out by some of you, open an editor:
    sudo gedit /etc/modprobe.d/blacklist
    12) Add to the end of the file:
    # Blacklist rt73usb, as it is a non-functional beta module which conflicts with the working rt73 module.
    blacklist rt73usb
    # Blacklist rt2570, as it causes conflicts with rt73
    blacklist rt2570
    # Other modules that break rt73
    blacklist rt2500usb
    blacklist rt2×00lib
    13) Load the module:
    sudo modprobe -v rt73
    14) Now you can play with RutilIT, click on menu: Applications/Internet/RutilIT...
    or
    15) Even better open interfaces:
    sudo gedit /etc/network/interfaces
    16)Add the following lines (for auto DHCP) according to your personal set-ups, but make sure to block (mask using #) all other references to eth0 or similar, if not this WON'T work:
    #auto eth0
    #iface eth0 inet dhcp
    auto wlan0
    iface wlan0 inet dhcp
    pre-up ifconfig wlan0 up
    pre-up iwconfig wlan0 essid YOUR_SSID
    pre-up iwconfig wlan0 mode managed
    pre-up iwpriv wlan0 set AuthMode=WPAPSK
    pre-up iwpriv wlan0 set EncrypType=TKIP
    pre-up iwpriv wlan0 set WPAPSK=YOUR_PASS_KEY_IN_HEXADEC
    Or (for manual DHCP)
    #auto eth0
    #iface eth0 inet dhcp
    auto wlan0
    iface wlan0 inet static
    address 192.168.1.2 (or what ever yours is)
    netmask 255.255.255.0 (or what .....)
    gateway 192.168.1.1 (or what .....)
    pre-up ifconfig wlan0 up
    pre-up iwconfig wlan0 essid YOUR_SSID
    pre-up iwconfig wlan0 mode managed
    pre-up iwpriv wlan0 set AuthMode=WPAPSK
    pre-up iwpriv wlan0 set EncrypType=TKIP
    pre-up iwpriv wlan0 set WPAPSK=YOUR_PASS_KEY_IN_HEXADEC
    17) Save the file,
    18) Reboot and you should be connected

    good luck =)

  3. #3
    Senior Member DaKahuna's Avatar
    Join Date
    Jan 2010
    Posts
    103

    Default

    I have to ask - why would anyone go through this. My RT73 device was detected and worked without having to do any of this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •