Results 1 to 3 of 3

Thread: .ISO CD/DVD boot record

  1. #1
    Just burned his ISO
    Join Date
    May 2007
    Posts
    13

    Default .ISO CD/DVD boot record

    Hi, I'm just wondering, I can't seem to get BT3 beta running on my Laptop:

    Toshiba Satellite 5205-S705

    as i noted in an earlier post:Trouble booting

    the specific error I'm pretty sure starts when I see:

    udevd-event[5167]: run_program: '/sbin/modprobe' abnormal exit


    Now I may be mistaken, but wouldn't/couldn't this error be caused by a hardware issue within modprobe like drivers not binding with a device? Looking through my device information on the laptop my IDE controller uses ata_piix driver

    I also seen this in the blacklist in /etc/modprobe.d

    So attempting to troubleshoot the issue myself, i removed the ata_piix from the blacklist and recompressed the etc directory into etc.lzm, created a new .iso and replaced etc.lzm in /BT3/Base

    now checking the current .iso boot record I see that it has: no emulation, is 2048 bytes in size its location is on the original image at 0x19000 and is not visible on the image

    my problem is merely not being able to reproduce the boot record from the current BT3 .iso so that I may boot my recreated .iso with the modified blacklist

    if thats even the answer to my problem, I'd just like to find out

    cheers to anyone that can help me or add some more air to my tank so i can dive deeper

    circuitbomb

    btw thanks secure_it for the tut for Vmware 6 bt3 install!! very good resource

  2. #2
    Just burned his ISO
    Join Date
    May 2007
    Posts
    13

    Default

    Well after a slew of crap crap and more crap - on figuring out .lzm ^^

    i modified the blacklist file by removing the ata_piix line...

    I had to lzm2dir the etc.lzm file which seemed to only let me extract it to /etc

    its my wonder that after i modified the file, i dir2lzm replaced etc.lzm and used make_iso.shm burned the image and now get an error

    /linuxrc: line 188: cannot create union/etc/fstab: nonexistent directory
    * changing root directory...
    linux live end, starting the Linux distribution
    INIT:version 2.86 booting
    INIT: No inittab file found

    Enter runlevel:1
    INIT: Entering runlevel: 1
    INIT: no more processes left in this runlevel

    im tired and my eyes are going crosseyed, xD

  3. #3
    Just burned his ISO
    Join Date
    May 2007
    Posts
    13

    Default

    n/m dont waste your time with this - sorry to waste your reading anc clicking - just realized that bt2 works fine on the lappy and blacklist file seems the same...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •