Results 1 to 2 of 2

Thread: Need help upgrading to latest kernel 2.6.24

  1. #1
    Junior Member sin_gage's Avatar
    Join Date
    Oct 2007
    Posts
    64

    Default Need help upgrading to latest kernel 2.6.24

    i am trying to upgrade to the latest kernel released , 2.6.24 but after compiling it i get error , unable to unable to mount root fs on unknown block and the options it shows is hda and mine is sda. Also added a line , root=/dev/sda2 but no help.
    :cool:" i had rather be hated for wat i am than to be loved for wat i am not ......":p

  2. #2
    Good friend of the forums
    Join Date
    Jan 2010
    Location
    outside chicago, il
    Posts
    442

    Default

    you probably forgot support for your filesystem. At a minimum ext2 and ext3 need to be compiled into the kernel (not modules). Here is the filesystem section from my 2.6.24 kernel .config file.
    #
    # File systems
    #
    CONFIG_EXT2_FS=y
    # CONFIG_EXT2_FS_XATTR is not set
    # CONFIG_EXT2_FS_XIP is not set
    CONFIG_EXT3_FS=y
    CONFIG_EXT3_FS_XATTR=y
    CONFIG_EXT3_FS_POSIX_ACL=y
    CONFIG_EXT3_FS_SECURITY=y
    # CONFIG_EXT4DEV_FS is not set

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •