Results 1 to 5 of 5

Thread: 3 little problems on BT3b (HDD-install already done)

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    3

    Default 3 little problems on BT3b (HDD-install already done)

    hi!

    i'm really new to backtrack/linux and i installed it to HDD on a dual boot system (xp+bt).
    almost everything works for me (not tested every prog...)! but there are some details i would like to fix.
    for example the problem with the not mounted bt-partition is already fixed by me (thx to this forum!).

    1. is it possible to automatically log in (root+toor) and automatically boot into KDE (xconf+startx)? is this done by the "syslinux.cfg"? this config is just on the bt-cd. it is not at the installed bt directories.

    2. how can i deactivate pcmcia? i don't need it and so i can save some ressources.

    3. when i tested the live-cd and quitted it, there were options like "shut down" and so on... at the installed version of backtrack there is only "end current session". when i coose this, bt wents to the "dos-promt" (<- sorry if this is the wrong term on linux. is it called "bash"?).

    i hope someone can help me.

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    1.If you do not like the command line logon and want the KDE desktop to start automatically.

    nano /etc/inittab

    change the following line:

    id:3:initdefault:

    to

    id:4:initdefault:

    2. http://backtrack.offensive-security....dex.php/Cheats -there are a variety of boot codes which can be enterd at start up or added to your lilo.conf

    3. I'm not sure mine says shut down. Try updating your distro with slapt-get. There is a section in bug and fix which goes over fixing slapt-get

  3. #3
    Member
    Join Date
    Dec 2007
    Location
    @InterN0T
    Posts
    315

    Default

    To answer question 3, the reason why this "problem" of yours is happening is because:

    When you boot with this: id:3:initdefault:
    Then you will allways only have the option to end the session, when you are out in the
    console, just write poweroff and bam! Your computer is just beginning to power off! :O
    If you would like a restart, write "restart" without quotes. (or maybe it was reboot)..

    When you boot with this: id:4:initdefault:
    You boot directly into KDE, and you will also have a lot more options when you start
    your menu. The reason why is because KDE is now operating as a real os, and not an
    application which runs on the "command line" interface.

    With id:4:initdefault: you will have more options to both reboot, poweroff, start
    another session, and much more You can also make it ask you for a login screen
    when you boot it up that way if you want ;D And you can of course customise that
    too. (i've done that when i pimped out my linux)

    That's my 2 cents
    [quote][I]I realized, that I had fallen down from the top of the mountain into a deep, terrifying and dark hole, just to find out that another mountain in front of me, much greater than the previous, was the next step in life. I began to wander uphill on the next mountain of life while I knew it would be much harder than the previous mountain. [/I]- MaXe[/quote]

  4. #4
    Junior Member
    Join Date
    Mar 2007
    Posts
    47

    Default

    I was a little curious on this subject as well. When I boot live with persistant changes it has the options to shut down and reboot, but since I'm now booting in compiz mode I lost them. I will try this method, thanks.

  5. #5
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    3

    Default

    wow! this really worked nice!
    it boots directly into KDE and shutdown is now also available. thank you!

    but adding "bt nopcmcia" as last line to my lilo.conf does not disable pcmcia oO
    is there another option?

    and: is it necessary to have lilo enabled on my hda2? because after normal booting, the windows xp bootmanager starts and asks me for booting into xp or backtrack. then i choose bt... and the ugly lilo bootmanager appears, asking me for booting into bt (only bt is available there). xD

    so how do i disable the lilo bootmanager?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •