Results 1 to 8 of 8

Thread: synaptics under bt3beta

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default synaptics under bt3beta

    Anyone got synaptics to work? I installed the slackware synaptics package, but xorg claims that I have no touchpad. I will post the logs soon.

  2. #2
    Just burned his ISO
    Join Date
    May 2008
    Posts
    1

    Default

    I know the thread is old, but I just got it to work after about an hour of fiddling around so here's how you do it:

    1. download the synaptics driver synaptics-0.14.6.tar.bz2 from the internet (forum won't let me post the URL just look on google)
    2. extract with tar xfvj synaptics-0.14.6.tar.bz2
    3. cd into synaptics-0.14.6 directory and run 'make' and 'make install'
    4. edit your /etc/X11/xorg.conf:

    - add the line
    InputDevice "touchpad" "CorePointer"
    in the section "ServerLayout" and comment out the line
    InputDevice "Mouse0" "CorePointer"
    in the same section.

    - add the line
    Load "synaptics"
    in the section "Module"

    - add this to the end of the file
    Section "InputDevice"
    Driver "synaptics"
    Identifier "touchpad"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "FingerLow" "25"
    Option "FingerHigh" "30"
    Option "MaxTapTime" "0" # disable annoying fingertip feature
    Option "MaxTapMove "0"
    EndSection
    save the file.

    5. now this is the most important part. if you don't do this, startx will fail and cat /var/log/Xorg.0.log will yield something like "(EE) Synaptics Touchpad no synaptics touchpad detected and no repeater device bla bla", at least on my IBM ThinkPad T41! Anyway open the file /etc/rc.d/rc.modules and search for psmouse. you should find a line looking like this
    /sbin/modprobe psmouse proto=imps
    Now change imps to any so that the line now reads
    /sbin/modprobe psmouse proto=any
    save the file and exit

    6. reboot and your synaptics driver should hopefully work

  3. #3
    Junior Member
    Join Date
    Dec 2007
    Posts
    27

    Default

    Unclear if this be helpful... running an old HP ZT1180 laptop w/ the Synapetics touch pad and there is an update at HP for this... I put the update into XP as I dual boot XP and BT3.

    I understand the XP drivers are on a separate partition and do not influence BT3 and are not used by BT3.

    However, the Synapetics touch pad has worked perfectly under BT3 w/o any editions/patches/etc...

    ... I set it up under BT3 using the xorgconfig screen of choices to pick for ones equipment being used and it's worked perfectly from first install.

    fwiw

  4. #4
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    I understand the XP drivers are on a separate partition and do not influence BT3 and are not used by BT3.
    Installing drivers in windows will have no effect on any of your other operating systems.

    5. now this is the most important part. if you don't do this, startx will fail and cat /var/log/Xorg.0.log will yield something like "(EE) Synaptics Touchpad no synaptics touchpad detected and no repeater device bla bla", at least on my IBM ThinkPad T41! Anyway open the file /etc/rc.d/rc.modules and search for psmouse. you should find a line looking like this

    Quote:
    /sbin/modprobe psmouse proto=imps

    Now change imps to any so that the line now reads

    Quote:
    /sbin/modprobe psmouse proto=any

    save the file and exit
    This part does however seem like something that could be helpful for me as I have not been able to get scrolling etc. enabled on my synaptics touchpad despite several attempts. Will try it as soon as I get home from work. Thanks for updating an old post with a solution you have found, not many people bother with doing this.
    -Monkeys are like nature's humans.

  5. #5
    Senior Member
    Join Date
    Apr 2008
    Posts
    2,008

    Default

    So I finally got around to try to get support for my synaptics touchpad again. I changed the
    Code:
    /sbin/modprobe psmouse proto=imps
    to
    /sbin/modprobe psmouse proto=any
    as per dizzy_one's suggestion and what do you know, on the next reboot I had both horizontal and vertical scrolling i.e. full support. I did however enable the fingertapping feature as I find it completely impossible to live without

    Thank you for posting this helpful solution
    -Monkeys are like nature's humans.

  6. #6
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    9

    Default

    Thanks for this synaptics help, I hate fingertapping, I always seem to end up dragging stuff around and clicking on random stuff. My USB mouse has it's share of problems too. Good Post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •