Results 1 to 10 of 17

Thread: Hydra 5.4 issue

Hybrid View

  1. #1
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default Hydra 5.4 issue

    I was trying to use Hydra today to work on the deice 1.100 livecd.

    When it came to the part to use hydra I fired it up, but when I clicked on start it gave me the following errors:

    Warning: child 0 reported error no 4, terminating it and restarting ...
    Warning: child 11 reported error no 4, terminating it and restarting ...
    Warning: child 13 reported error no 4, terminating it and restarting ...
    Warning: child 14 reported error no 3, terminating it and restarting ...
    Warning: child 15 reported error no 3, terminating it and restarting ...
    Warning: child 16 reported error no 3, terminating it and restarting ...
    Warning: child 18 reported error no 4, terminating it and restarting ...
    Warning: child 19 reported error no 3, terminating it and restarting ...
    Warning: child 20 reported error no 3, terminating it and restarting ...
    Warning: child 21 reported error no 3, terminating it and restarting ...
    Warning: child 22 reported error no 3, terminating it and restarting ...
    Warning: child 24 reported error no 4, terminating it and restarting ...
    Warning: child 25 reported error no 3, terminating it and restarting ...
    Warning: child 26 reported error no 3, terminating it and restarting ...
    Warning: child 27 reported error no 3, terminating it and restarting ...
    Warning: child 28 reported error no 3, terminating it and restarting ...

    I tried it on another machine with the same result.

    Afterward I compiled apr,apr-utils and hydra 5.3. That one is working without an issue, after linking the 5.3 binary into /usr/local/bin the xhydra was working correctly too.

    Not sure what the issue is exactly, trying to figure it out or if someone else knows a fix already, let me know please.

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    If you do not have a bug and a fix don't post in the bug and fix section.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    12

    Default

    thats not a bug...
    the service your using hydra against has taken steps to prevent you from trying a lot of logins,
    by one means or another(blacklisting, timeouts, one login per ip, etc..)

  4. #4
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    At first, sorry for posting in the wrong forum, I will pay better attention to it in the future.

    @Ferdinand

    Why isn't it a bug, if it is working with Hydra 5.3 but not 5.4?

  5. #5
    Member
    Join Date
    Dec 2007
    Location
    @InterN0T
    Posts
    315

    Default

    You need to set some proper options for Hydra in 5.4 i believe, i managed to get it to
    work in 5.4 by setting up correct timing, and a lot of other options. (i think the command
    line was atleast a whole full line for itself, even though yes i got similar messages once
    and in a while simply due to the host didn't have enough bandwidth and power to process
    the login attempts. But i believe real hosts would blacklist you.

    Cracking is allways last thing i would do. (seeing as it's also highly detective)
    [quote][I]I realized, that I had fallen down from the top of the mountain into a deep, terrifying and dark hole, just to find out that another mountain in front of me, much greater than the previous, was the next step in life. I began to wander uphill on the next mountain of life while I knew it would be much harder than the previous mountain. [/I]- MaXe[/quote]

  6. #6
    Moderator KMDave's Avatar
    Join Date
    Jan 2010
    Posts
    2,281

    Default

    Well today I was reinstalling BT3 in a new created vm. I just tried it with my local host to give it a try and it did work. Haven't had the time to fire up the DEIce 1.100 again to try it there.

    I will let you know later on if I got it working or received an error message again.

    And why I was using hydra is simply that I was following the tools DEIce suggests and purehate is also showing in his video walkthrough.

    Since I like to get some hands on experience I tried to follow the steps from the tutorial and understand it.

    Hydra 5.3 was working like a charm returning the wanted result for bbanter and aadams.

    But I wanted to help to contribute a part, even it is really really small, in finding out if it is a general issue or maybe even only with my setup for some reason.

    Thanks

    Edit:

    Thanks also about the hint about cracking. Since it was just in my lab environment I don't have to care about being pretty "noisy" but good to keep in mind for the "real world".
    But also might be good to test an IDS setup.

  7. #7
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    12

    Default

    It's not a bug, because it's responding to the correct stimulus.
    I suppose the default settings on .4 are different from .3
    (spoiler warning)
    Well I looked over hate talk's suggestions.
    I did it a bit differently to save some time.
    Instead of using hydra against ssh.(which still will work, just lower the children and up the timeout, like 8 children and a timeout of 70 should do it)
    I used it against pop3, both from the email version adamsa, and from the login version aadams. turns out aadams was the correct form, not the email address version.(I was able to use 15 children a timeout of 30, but it'll vary network to network)

    Hydra works fastest against pop3(I divided the passlist I was using between a friend and I, and we cracked it in about 3 minutes). Read the man pages for hydra.

    Know your tools, know your error messages.

    Whole challenge with two people working at it, took about 30 minutes. 5 minutes was lost due to incorrect login information, i.e. banterb. Hopefully the next ones will be more challenging.

    Jake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •