Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ati-driver installation error

Hybrid View

  1. #1
    Junior Member SWFu64's Avatar
    Join Date
    Jan 2010
    Posts
    97

    Default ati-driver installation error

    When trying to install ati-driver/backtrack-ati I recieve the following error:

    Code:
    trying to overwrite `/usr/lib/libGL.so', which is also in package libgl1-mesa-dev
    Processing triggers for man-db ...
    Errors were encountered while processing:
    /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    This is on a fresh HD install in basic text mode. I've the same issue on both machines I have tested this on, a Dell Studio 16 XPS/4670 and a custom build running a 4870X2.

  2. #2
    Developer muts's Avatar
    Join Date
    Jan 2006
    Posts
    272

    Default Re: ati-driver installation error

    There are two problems, one hidden and one not.
    The ATI driver will have to overwrite libGL.so ...
    dpkg -i --force overwrite /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb should work...BUT DONT DO IT YET.

    I believe the ati-driver hasn't been updated TO The running kernel. We are working on it...

  3. #3
    Just burned his ISO leonidas79's Avatar
    Join Date
    Jan 2010
    Posts
    2

    Question Re: ati-driver installation error

    I have same problem. I solved when I download ati drivers from Graphics Drivers & Software and install (manual is here https://a248.e.akamai.net/f/674/9206...at912-inst.pdf).

    After that I have only problem with resolution.I choose and apply resolution but when I reboot resolution is old (before change). Anybody help?

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default Re: ati-driver installation error

    If you install source packages rather than wait for us to get a proper package going it makes it very hard for us to support and help you.

  5. #5
    Junior Member SWFu64's Avatar
    Join Date
    Jan 2010
    Posts
    97

    Default Re: ati-driver installation error

    Great work guys, any testing you want done here on ATI cards let me know!
    "I do not know with what weapons World War III will be fought, but World War IV will be fought with sticks and stones."

    Albert Einstein

  6. #6
    Just burned his ISO
    Join Date
    Jan 2010
    Posts
    2

    Default Re: ati-driver installation error

    Can i ask when this major bugfix coming out ?
    Or can we get linux-header linux-image or anything to work out or build ati package.

  7. #7
    Member
    Join Date
    Jan 2010
    Location
    Helsinki, Finland
    Posts
    235

    Default Re: ati-driver installation error

    Quote Originally Posted by muts View Post
    There are two problems, one hidden and one not.
    The ATI driver will have to overwrite libGL.so ...
    dpkg -i --force overwrite /var/cache/apt/archives/ati-driver_9.5-bt2_i386.deb should work...BUT DONT DO IT YET.

    I believe the ati-driver hasn't been updated TO The running kernel. We are working on it...
    Do you know when this important update is coming?

  8. #8
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default Re: ati-driver installation error

    Quote Originally Posted by halfdone View Post
    Do you know when this important update is coming?
    The general answer to such questions are 'it will be done when it's done'. I know it's not the best answer but it's the only one as of now. Furthermore you and others might try checking the repo to see if there is a new package available.

  9. #9
    Just burned his ISO HAL9000's Avatar
    Join Date
    Mar 2010
    Posts
    11

    Default Re: ati-driver installation error

    I have succssfully installed the ATI drivers in my PC and now BT4 is running with the maximum resolution
    I have and HD4530 card and I have installed the drivers dowloading the ati-driver-installer-10-2-x86.x86_64.run from ATI web site.

    The only problem I got it was to manually update the xorg.config file with the one from ATI...I do not why the automatic installation does not update it.

    Enjoy....

  10. #10
    Just burned his ISO leonidas79's Avatar
    Join Date
    Jan 2010
    Posts
    2

    Default Re: ati-driver installation error

    Quote Originally Posted by HAL9000 View Post
    I have succssfully installed the ATI drivers in my PC and now BT4 is running with the maximum resolution
    I have and HD4530 card and I have installed the drivers dowloading the ati-driver-installer-10-2-x86.x86_64.run from ATI web site.

    The only problem I got it was to manually update the xorg.config file with the one from ATI...I do not why the automatic installation does not update it.

    Enjoy....
    Please, explain how do you do that (update the xorg.config)?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •