Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: ATi / Radeon Graphics (newer chipsets - fixed my X1250 graphics)

  1. #21
    Just burned his ISO
    Join Date
    Jun 2007
    Posts
    3

    Default

    Can you upload the full iso or a rar of the files you have on your USB would be greatly appreichiated thx

  2. #22
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    8

    Thumbs down

    Quote Originally Posted by ;
    3.
    This finally got me booting into KDE, and for me it was at the highest resolution of 1280x800. However, in order to change the graphics resolution, the ATi Catalyst Control Center is needed, and although it was present on the start menu, it would not start. It was missing some file package dependencies. To get that working took some reading of ATi's installation notes, and finding some Slackware packages it needed. The ATi Catalyst Control Center is dependent on:

    * Qt (library)
    * gcc-g++ (C++ library)
    * cxxlibs (a Slackware file for backward compatibility with previous gcc-g++ libraries)

    A little poking around in the libraries once it was booted found the BT3 Beta distro came with the gcc 4.1.2 C library already, it only needed the C++ module added, and I found it and a compact QT library for Slackware 12 on the Slackware package distribution site (gcc-g++-4.1.2-i486-1.tgz and qt-3.3.8-i486-5_slack12.0.tgz). Both of these were converted to Slax "lzm" files by placing the "tgz" files into the "rootcopy" directory, and using the "tgz2lzm" command on them. The resulting "lzm" versions were then placed into the "modules" directory. The backward compatibility file turned out to be very hard to find, but finally located a "cxxlibs-6.0.8-i486-4.tgz" file, also on the Slackware package site (under Slackware 12). If "amdcccle" (name of Catalyst Control Center binary) is entered on a command line, a specific, older C++ file library (version 5) cannot be found. The problem with the "cxxlibs-6.0.8-i486-4.tgz" is where it wants to place its files -- under the "usr/lib" directory in the "i486-slackware-linux" subdirectory (in "usr/i486-slackware-linux/lib" instead of "usr/lib"). This doesn't work as "amdcccle" for the C++ files it needs in the "usr/lib" directory. The file structure inside the "tgz" had to be modified along with its "doinst.sh" shell script that installs the files. I had to pace the "tgz" in the rootcopy directory, unpack the "tgz" archive (using ark), move the C++ files to the "usr/lib" directory, modify the "doinst.sh" shell script accordingly (to put the new files into the "usr/lib" directory), repack it into a "tgz" archive, and then use the "tgz2lzm" command to make an "lzm" out of it. Once it was placed into the "modules" directory, along with the QT and gcc-g++ libraries, the ATi Catalyst Control Center came to life.



    Hello, i've made it that far in this tutorial, but im a little unclear of what to do with the cxxlibs. I've extracted it with ark, and it produced 3 folders. I'm not sure what to change in the script, or what part of the file structure i'm supposed to change. I know this is an old thread and i'm hoping someone will see this. Any help is much appreciated. Thanks.

  3. #23
    Just burned his ISO
    Join Date
    Jun 2008
    Posts
    1

    Default

    I was going to post on this - but I'll add the only bit I didn't see to this one instead. If you are using a samsung laptop (or from what I gather having travel the t'internet for ages any samsung monitor) you may have a further problem.

    Hardware: Samsung R40+ (ATI x1250)

    Effect: "no useable screens" or "not supported Depth(8)" on startx
    or the "display(null)" message when using fglrxinfo. (if you're using an ati graphics card and don't know what I'm on about start at "http: // m.domaindlx.com/LinuxHelp/ati/ati.htm"

    There is one last change - xorg.conf.

    1) To make the change you'll need to know what resolutions and refresh rates your monitor supports (if like me you are more at home on windows use
    display settings -> advanced settings -> list all modes

    2) Ensure you've gone through the Ati Catalyst drivers installation mentioned above first

    3) run the following after logging in "root" "toor":

    Code:
    cd /etc/X11
    mc
    4) select xorg.conf, press F4 to edit

    Find the section "Screen", add a line under "Monitor" for "DefaultDepth 24" (as startx seems to pick depth 8 by default otherwise)
    , delete any other Subsection "Display" entries than the one for 24 and add one of your card/monitors valid modes/refresh rates. Here is mine below

    Code:
    Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor   "Monitor0"
        DefaultDepth 24
        SubSection "Display"
            ViewPort 0 0
            Depth     24
            Modes "1280x800_59"
        EndSubSection
    where the resolution i was after was 1280 x 800 (obvious) and the _59 is the refresh rate. What originally caught my laptop out was the assumed default refresh rate was not supported by my monitor.

    5) Save with F2, confirm and quit midnight commander.
    6)
    Code:
    cd /root
    startx.
    Further errors indicate that the mode is wrong, a blank screen most likely means that the refresh rate you (didn't) choose was unsupported

    The whole thing is *way* easier if you use the swap and changes partitions to persist your live CD installation.

    Good luck!


    What a baptism of fire my very first linux experience was! I'm now not so scared of the beast, and have passed the first test in my companies ethical hacker course ("get you're laptop working"). Penetration testing here we come.

  4. #24
    Junior Member
    Join Date
    Feb 2010
    Posts
    43

    Default

    I have Packard Bell laptop with x1250 ati graphic card, and i have finally succeeded to see KDE on my desktop with below steps;

    downloaded latest driver from ati page,

    ati-driver-installer-8-11-x86.x86_64.run

    created modules with command;

    ./ati-driver-installer-8-11-x86.x86_64.run --buildpkg Slackware/All

    this command produced 2 tgz files, then i have created modules with tgz2lzm command for both files.

    booted with "BT3 Text mode Frame Buffer" mode, at command prompt typed

    aticonfig --initial --force

    this modified the file under /etc/X11/xorg.conf as per my card, then i was able to start KDE with startx

    in order to make my settings permanent, i extracted /BT3/base/etc.lzm file with lzm2dir command to my desktop (/root/Desktop/etc/X11),
    copied newly created /etc/X11/xorg.conf file to the extracted folder (/root/Desktop/etc/X11). with dir2lzm command,
    recreated the etc.lzm module with new xorg.conf file (be carefull that lzm has the same folder structure as original like etc/X11/xorg.conf )
    then copied etc.lzm to my usb stick /BT3/base/ folder.

    thats it !!

    ps. make sure you have kernel.lzm in your BT3/base folder.

    i have read a tutorial but not tried yet, by coppiying the new modified xorg.conf file in iso to /BT3/rootcopy/etc/X11 folder may also work.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •