Results 1 to 2 of 2

Thread: autopwn in Metasploit 3.0

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    4

    Default autopwn in Metasploit 3.0

    So, I have installed all the packages required by metasploit for autopwn. rails, gems, dev packages etc etc. Anyway, I load the sqlite3 plugin. There isn't a problem there but when I go to use db_create I recieve this error

    [-] Error while running command db_connect: This plugin failed to load: Failed to connect to the database

    Call stack:
    /home/user/framework-3.0/plugins/db_sqlite3.rb:67:in `cmd_db_connect'
    ./lib/rex/ui/text/dispatcher_shell.rb:230:in `run_command'
    ./lib/rex/ui/text/dispatcher_shell.rb:196:in `run_single'
    ./lib/rex/ui/text/dispatcher_shell.rb:191:in `run_single'
    ./lib/rex/ui/text/shell.rb:125:in `run'
    ./msfconsole:77

    Now I do have sql running as a process. What am I doing wrong?

  2. #2
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    4

    Default

    I solved it. Basically I was trying to use a postgres database/plugin and I was also using rails version 2.0.2 instead of 1.2.2. When I removed all the 2.0.2 gems and the postgres plugin it works fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •