Results 1 to 7 of 7

Thread: error network requires encryption to be enabled

  1. #1
    Just burned his ISO
    Join Date
    Jan 2010
    Location
    Poland/UK
    Posts
    4

    Default error network requires encryption to be enabled

    Hi guys when im using Wicd Manager and i try to connect to my network i got an error "This network requires encryption to be enabled" I also have question about packed injection with card "intel 3945abg" it must be a specjal card with support or every card with specjal driver

    ps. if i make any mastake in writing im realy sorry english is not my native language

  2. #2
    Super Moderator lupin's Avatar
    Join Date
    Jan 2010
    Posts
    2,943

    Default Re: error network requires encryption to be enabled

    Quote Originally Posted by qpens8 View Post
    Hi guys when im using Wicd Manager and i try to connect to my network i got an error "This network requires encryption to be enabled"
    That means the network you are trying to connect to is protected using either WEP or WPA, and you need to authenticate, probably with a wireless key or password, before you can connect.
    Capitalisation is important. It's the difference between "Helping your brother Jack off a horse" and "Helping your brother jack off a horse".

    The Forum Rules, Forum FAQ and the BackTrack Wiki... learn them, love them, live them.

  3. #3
    Member muminrz's Avatar
    Join Date
    Jan 2010
    Posts
    64

    Default Re: error network requires encryption to be enabled

    Musisz ustawic to w "Advanced Settings", znajrziesz te opcje po nacisniencu malego "Ttojkanta" przed nazwa sieci

  4. #4
    Member
    Join Date
    Feb 2010
    Posts
    103

    Red face Re: error network requires encryption to be enabled

    Quote Originally Posted by muminrz View Post
    Musisz ustawic to w "Advanced Settings", znajrziesz te opcje po nacisniencu malego "Ttojkanta" przed nazwa sieci
    Do not get me wrong but you should post it also in english as not everybody understands polish.

  5. #5
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: error network requires encryption to be enabled

    Quote Originally Posted by muminrz View Post
    Musisz ustawic to w "Advanced Settings", znajrziesz te opcje po nacisniencu malego "Ttojkanta" przed nazwa sieci
    You forgot something... Not everyone in this forums speaks that language, and english nowadays is an international language. Although it is a relatively easy solution, others might need and appreciate an english response.

    EDIT: For those interested in the answer, what muminrz meant was: Click on the arrow next to the network SSID, click on Advanced Settings. The next window should be self explanatory.
    Last edited by Snayler; 02-03-2010 at 06:44 AM.

  6. #6
    Member muminrz's Avatar
    Join Date
    Jan 2010
    Posts
    64

    Default Re: error network requires encryption to be enabled

    Sorry my bad

  7. #7
    Junior Member Valkyrie's Avatar
    Join Date
    Jan 2010
    Posts
    49

    Default Re: error network requires encryption to be enabled

    Ok, Ill try third time lucky- just typed out this message twice then lost the message..


    I've got the same issue, I've tried 2 methods to try and fix it.

    1) changed VMsettings --> Bridged
    ifconfig eth0 up
    dhclient eth0
    menu--> start networking
    menu --> wicd (shows wireless networks though wont let me connect, even though I've entered the network key.)

    It says at bottom of wicd "Connected to WIRED network IP: 192.168.0.7"
    So..I disconnect the Wired connection and try connect to the wireless again..sayd trying to authenticate but
    then doesnt connect.

    Also, with the above method, When I click on an 'Unsecured network'in my list it says
    'This network requires encryption to be enabled'.

    2) ---> Disable laptop internal wireless
    change VM settings ---> NAT
    VM settings---> untick auto connect usb,network card
    ifconfig wlan0 up
    dhclient wlan0
    menu--> start networking
    menu --> wicd ---> NO wireless networks detected.

    Can anyone tell me what Im doing wrong?

    EDIT: After hours of trial and error noobing around on google I've got wireless working..
    1) My /etc/network/interfaces file was incorrect
    2) After fixing it just followed the darn tutorial..
    root@bt: update-rc.d networking defaults
    root@bt: sshd-generate
    root@bt: update-rc.d ssh defaults
    Filled in static IP details in wicd -->advanced section --> used WEP shared/restricted (for normal wep key)
    voila
    Last edited by Valkyrie; 02-03-2010 at 05:32 PM. Reason: My Problem solved..yay

Similar Threads

  1. Full HD encryption with Luks and LVM
    By Ulrick13 in forum Beginners Forum
    Replies: 4
    Last Post: 02-01-2010, 03:12 PM
  2. Two Kernel options that should be enabled
    By trellis in forum Tool Requests
    Replies: 1
    Last Post: 01-23-2010, 05:39 PM
  3. Bt- 4 serieas problem error error
    By lenien in forum Beginners Forum
    Replies: 2
    Last Post: 01-18-2010, 06:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •