Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 96

Thread: slapt-get

  1. #21
    Member
    Join Date
    May 2007
    Posts
    53

    Default Why so many servers?

    Quote Originally Posted by pureh@te View Post
    The newest version is the e version. that is what you need.
    Thanks Purehate... that was a bit thick of me.

    continueing with the thick questions. I've installed the E version of slapt-get.

    Opening the /etc/slapt-get/slapt-getrc file shows me loads of different mirrors, from which i would be able to download the updates from.

    My question is...is there any difference between the servers? or do they all contain the same software packages?

    If so, what makes me pick one server over another? Or is it a case of server-x will contain different software packages to server-y and therefore the more active servers you have defined in the slapt-getrc file, the more choices you have?

  2. #22
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    The reason is that although they should all have the same packages, some are slower at getting the latest packages than others, also some servers can be overloaded with people updating at the same time so can become slow. Although it is recommended to chose a server nearest to you, that is not always the best server to use, so it can often be faster to use a server on the other side of the world than it can be using one 100 miles from you.

  3. #23
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default GPGME: Invalid crypto engine when using slapt-get

    Again with the errors about using slapt-get or the gui

    If you get the error GPGME: Invalid crypto engine this indicates that you dont have the proper or no gpg keys so you have to add them if necessary.

    also from the slapt-get faq : Recent versions of slapt-get support GPG key verification via the GPGME library. GPGME requires gnupg to support the OpenPGP protocol. At this time gnupg2 is not compatible with GPGME and so gnupg must also be installed. gnupg 1.x can be installed side by side with gnupg2.

    So if it is still not working try to use the mirror provided by Dr. GrEen in this thread. you may still have to use the --no-md5sum to get the downloads to work.
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  4. #24
    Member
    Join Date
    Feb 2007
    Posts
    229

    Default

    i have a fresh install, updated slapt-get, reinstalled gslapt, and got this:

    gslapt: symbol lookup error: gslapt: undefined symbol: slapt_init_source_list

    ...huh? anyone know what this is all about?

  5. #25
    Junior Member
    Join Date
    Oct 2007
    Posts
    25

    Default

    I've got a question I need some library's off the Slackware dvd i downloaded to compile some apps I need to compile. I'm pretty new but can I setup slapt-get to search my dvd for these library because the site don't carry allot of the packages on the cd/dvd

    This is what I tried
    Code:
    WORKINGDIR=/var/slapt-get
    EXCLUDE=^kernel-.*
    
    SOURCE=http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/
    SOURCE=ftp://mirrors.blueyonder.co.uk/sites/ftp.slackware.com/slackware-current
    #Tryed this to get packages off the DVD-Rom drive
    SOURCE=mnt/cdrom/
    SOURCE=file:///mnt/cdrom/

  6. #26
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Trigger I have no clue what you are trying to do it makes no sense however here is the repo for libraries. I hope you find what you need there or explain your situation a little better.


    SOURCE=mnt/cdrom/
    SOURCE=file:///mnt/cdrom/

    this simply makes no sense and will not work

  7. #27
    Junior Member
    Join Date
    Oct 2007
    Posts
    25

    Default

    I'm Trying to change out my players to the ones i like to use and to get more codecs. but im missing some dependency's.
    But heres a picture of my problem
    But the dvd rom source i was trying i found on another forum and the person must have the amount know how as me lol


  8. #28
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    You will probably have to do all the dependancies one by one with slapt-get and the repo i linked you to should have every thing you need.

  9. #29
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    if you want to install a package from the slackware dvd use installpkg. As for the dependencies you will have to install them before the rest. I can see one is libtool but couldn't make out the rest.

    Code:
    slapt-get --install libtool

  10. #30
    Junior Member
    Join Date
    Oct 2007
    Posts
    25

    Default

    Ok i added the source and did #slapt-get --dist-upgrade i got everything needed thanks alot.

Page 3 of 10 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •