Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 96

Thread: slapt-get

  1. #11
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    If I could get someone to confirm or deny this fix I would appreciate it


    Not me I installed the newest slapt-get and then I......

    root@backtrack ~ # slapt-get --update && slapt-get --upgrade


    and now I ....

    root@backtrack / # slapt-get --version
    slapt-get version 0.9.10e

    So I am still good.I will update again to see.

    EDIT: still good

    root@backtrack / # slapt-get --update && slapt-get --upgradeRetrieving package data [ftp://slackware.cs.utah.edu/pub/slac...2.0/]...Cached
    Retrieving patch list [ftp://slackware.cs.utah.edu/pub/slac...2.0/]...Cached
    Retrieving checksum list [ftp://slackware.cs.utah.edu/pub/slac...2.0/]...Cached
    Reading Package Lists...Done
    Retrieving package data [http://software.jaos.org/slackpacks/12.0/]...Cached
    Retrieving patch list [http://software.jaos.org/slackpacks/12.0/]...Cached
    Retrieving checksum list [http://software.jaos.org/slackpacks/12.0/]...Cached
    Reading Package Lists...Done
    Retrieving package data [http://darkstar.ist.utl.pt/slackware...2.0/]...Cached
    Retrieving patch list [http://darkstar.ist.utl.pt/slackware...-12.0/]...Done
    Retrieving checksum list [http://darkstar.ist.utl.pt/slackware...2.0/]...Cached
    Reading Package Lists...Done
    Reading Package Lists... Done
    The following packages have been EXCLUDED:
    alsa-oss ruby compizconfig-python alsa-utils alsa-lib
    0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

    Done

  2. #12
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006
    Posts
    1,031

    Default

    I upgraded, now it all works. veddy nice.

    confirmed.
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

  3. #13
    Junior Member
    Join Date
    Aug 2007
    Posts
    37

    Default

    still i cannot dis confirm the fix...

    so i guess this is a permanent fix

  4. #14
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    Quote Originally Posted by Dr_GrEeN View Post
    archangel.amael please follow instructions carefully and don't rush m8. Put the repo in properly and it will work !
    ahhh! just what the doctor ordered and it worked! Thanks Dr. GrEeN.

    any rate the point was I c/p alot of the mirrors and none of them seemed to work for me.
    So I checked it today a few more times and the only one that i got to work is the one listed below.


    Code:
    http://darkstar.ist.utl.pt/slackware/addon/slacky/slackware-12.0/
    [/QUOTE]

    On another note it seems that slapt-get version 0.9.12a was the version I was using is the one that caused so many problems. however just installed .c and all seems to be working better.



    EDIT: I was also looking in the slapt-get 0.9.12.a faq under /usr/doc/slapt-get-0.9.12a/FAQ
    and noticed the following:



    53. Does slapt-get support the GPG/PGP signature verification?

    Yes, as of 0.9.12 slapt-get can be built with gpgme support that allows
    slapt-get to verify the signature of the CHECKSUMS file on each mirror.
    This requires the presence of the signature file and the GPG-KEY file on
    the package source. The GPG-KEY is imported into the local keychain using
    the --add-keys option. When running --update, the signature file for the
    CHECKSUMS listing is downloaded and verification is attempted. If the key
    is not present slapt-get mentions this and continues on. slapt-get only halts
    if verification failed.


    54. Why am I getting "GPGME: Invalid crypto engine"?

    Recent versions of slapt-get support GPG key verification via the GPGME
    library. GPGME requires gnupg to support the OpenPGP protocol. At this
    time gnupg2 is not compatible with GPGME and so gnupg must also be installed.
    gnupg 1.x can be installed side by side with gnupg2.

    The second seem to explain why some people are having troubles with using slapt-get and gslapt
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  5. #15
    Junior Member bwise's Avatar
    Join Date
    Nov 2007
    Posts
    69

    Default

    it seems when i install manually slapt-get then Gslapt package manager stops working. it does not even start. Can someone also confirm this ?

  6. #16
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I will take a look bwise. To be honest I never use the gslapt package manager i prefer to do it from the command line however I know a lot of people like to use it so we will see if we can get it going.

  7. #17
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    reinstall gslapt its only a gui for slapt-get

    Code:
    slapt-get --update && slapt-get --install --reinstall gslapt

  8. #18
    Junior Member bwise's Avatar
    Join Date
    Nov 2007
    Posts
    69

    Default

    thanks for trying to help purehate , and thanks DrGreen for resolving the problem

  9. #19
    Member
    Join Date
    May 2007
    Posts
    53

    Default its always the 'verifying checksum signature'

    Initially I had the same problem with slapt-get.

    I have upgraded slapt-get to the latest 'c' version; and have rerun slapt-get, but the errors are always on the same part...is on the "verifying checksum signature" part of the process.

    Now, i know that there is an option of "--no-md5" to override the MD5 checking, but is there an option to override the verifying checksum signature part.

    Cheers

    ***EDIT Ok... further analysis yielded that before all those new "verifying checksum signature" things will work, i have to perform the "--add-keys" option. Trying this new option yields the error "Invalid Crypto Engine" Which is my current path of investigation***

  10. #20
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Quote Originally Posted by mcai8rw2 View Post
    Initially I had the same problem with slapt-get.

    I have upgraded slapt-get to the latest 'c' version; and have rerun slapt-get, but the errors are always on the same part...is on the "verifying checksum signature" part of the process.

    Now, i know that there is an option of "--no-md5" to override the MD5 checking, but is there an option to override the verifying checksum signature part.

    Cheers
    The newest version is the e version. that is what you need.

Page 2 of 10 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •