Results 1 to 7 of 7

Thread: bt4 persistent not persistent

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Default bt4 persistent not persistent

    the changes i make in bt4 persistent on a usb are not kept after rebooting. everything else seems to be working properly including internet because i am writing this post from bt4. are there any other settings that need to be selected other than choosing BT4 Persistent from the boot menu?

  2. #2

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Default Re: bt4 persistent not persistent

    i followed those instructions except i used unetbootin to create the bootable usb

  4. #4
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default Re: bt4 persistent not persistent

    Quote Originally Posted by ample View Post
    i followed those instructions except i used unetbootin to create the bootable usb
    Then you didn't follow those instructions.

    How many partitions do you have on the stick ?
    How are they formatted (fat32,ext2,ext3,ntfs) ?
    What are the partition labels ?
    What menu entry are you selecting when you boot ?

  5. #5
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Default Re: bt4 persistent not persistent

    fair enough. i followed the steps in the video. everything ran smoothly until i rebooted to the usb and it dropped me into a grub command line. ive found 1 or 2 other people mention the same problem on the forums but no one has responded to them. the only difference is i performed the steps in ubuntu instead of backtrack. im not sure if this could cause the problem unless there is a difference between the grub-install commands in ubuntu and backtrack.

    edit: out of curiousity, i wrote down the kernel and initrd lines listed under the persistent entry in menu.lst, and manually typed them into the grub command line. unsurprisingly, it booted up into the persistent version of bt4, which does keep changes after reboot. the only problem is that on every startup i have to manually type the kernel and initrd lines into the grub command line. has anyone experienced this problem before? is grub not loading menu.lst for some reason?
    Last edited by ample; 02-04-2010 at 11:10 AM.

  6. #6
    Just burned his ISO darkdragn's Avatar
    Join Date
    Jan 2010
    Location
    Norfolk, VA
    Posts
    7

    Default Re: bt4 persistent not persistent

    Ok, first thing's first. You went through with ubuntu, are you sure that it's the same version of grub in ubuntu? There could've been a keyword in the menu.lst that an older version doesn't recegonize, and it's in turn panicing. Having said so, with the use of unetbootin the damage is done, and your jump drive will only want to boot with syslinux, unless you do dd if=/dev/zero of=/dev/sdx , or at least in my experences syslinux doesn't want to come off. If you have ever used unetbootin with that jump drive in the past, and not zeroed it out it would try to boot with syslinux, and with no config give you a boot: prompt, so are you sure it was a grub boot prompt. And, just to wrap things up, as long as you have an ext3 partition named casper-rw with a block size of 4096 (yeah... block size has messed me up in the past... *painful flash back* I don't want to think about it) and the arguments getting appended to the kernel include persistent, as opposed to nopersistent, even syslinux will boot with a persistent load.
    I hope this helped some, and good luck, man.
    Last edited by darkdragn; 02-07-2010 at 10:48 PM.

  7. #7
    Junior Member
    Join Date
    Jan 2010
    Posts
    41

    Default Re: bt4 persistent not persistent

    Yeah, l had same problem when l partitioned the USB into FAT and EXT3 using Gparted.
    lt only worked when l followed the advice in the HOW-TO section called:

    Backtrack 4 – USB/Persistent Changes/Nessus

    First l had to use the format method they suggest:

    mkfs.vfat /dev/sdb1
    mkfs.ext3 -b 4096 -L casper-rw /dev/sdb2

    because Gparted doesn't do the same thing it seems!!!

    Then l just edited the menu.lst file in grub:

    cd /mnt/sda1/boot/grub

    vi menu.lst

    like so:
    # change the default line below to ‘default 4′ and append ‘vga=0×317′ (that’s a zero) to the kernel line to set the resolution to 1024×768

    Voila lol.

Similar Threads

  1. BackTrack 4 Persistent USB Install Video
    By balding_parrot in forum BackTrack Videos
    Replies: 9
    Last Post: 12-14-2010, 05:15 PM
  2. Persistent USB Install Size
    By clutch in forum Beginners Forum
    Replies: 4
    Last Post: 02-14-2010, 07:20 PM
  3. Persistent excess
    By darkdragn in forum Beginners Forum
    Replies: 0
    Last Post: 01-27-2010, 06:13 AM
  4. BackTrack 4 with Ubuntu all persistent on the same USB key
    By mathieu in forum BackTrack Howtos
    Replies: 2
    Last Post: 01-19-2010, 03:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •