the GTK in my usb image was way out of date. it was 1.2. just thought id let you know.