Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Gslapt errors

  1. #11
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    slapt-get --add-keys does nothing

  2. #12
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010
    Location
    Somewhere
    Posts
    8,012

    Default

    When changing your sources in the /etc/slapt-get/slapt-getrc:
    file it may be best to find a mirror that is close you and use that one instead.
    here is the link to the mirrors that host slackware
    http://www.slackware.com/getslack/
    that way you get one that is closer or faster.

    also make sure that you get the link for the 12.0 or "current" sources
    To be successful here you should read all of the following.
    ForumRules
    ForumFAQ
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #13
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Can I also point out this isn't glsapt its slapt-get gslapt is the gui for slapt-get.

    Code:
    slapt-get --install gslapt
    Might be a bit better as it's abit easier to use and search packages ETC.

    @ purehate --add-keys does it retrieves the GPG keys.

  4. #14
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Quote Originally Posted by Dr_GrEeN View Post
    Can I also point out this isn't glsapt its slapt-get gslapt is the gui for slapt-get.

    Code:
    slapt-get --install gslapt
    Might be a bit better as it's abit easier to use and search packages ETC.

    @ purehate --add-keys does it retrieves the GPG keys.
    I tried that guys fix because muts wanted me to gather all the fixes in one place on the wiki but the add keys flag does not work and its not listed under slapt get help so I can only assume it doesnt work. The author of that post needs to make himself more clear and add some documentation if he wants it fixed in bt3 final.

  5. #15
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    it is pureh@te

    Code:
    drgr33n ~ # slapt-get --help
    slapt-get - Jason Woodward <woodwardj at jaos dot org>
    An implementation of the Debian APT system to Slackware
    Usage:
    slapt-get [option(s)] [target]
    
    Targets:
      --update|-u    - retrieves pkg data from MIRROR
      --upgrade      - upgrade installed pkgs
      --dist-upgrade - upgrade to newer release
      --install|-i   [pkg name(s)] - install specified pkg(s)
      --install-set  [disk set(s)] - install specified disk set(s)
      --remove       [pkg name(s)] - remove specified pkg(s)
      --show         [pkg name] - show pkg description
      --search       [expression] - search available pkgs
      --list         - list pkgs
      --available    - list available pkgs
      --installed    - list installed pkgs
      --clean        - purge cached pkgs
      --autoclean    - only purge cache of older, unreacheable pkgs
      --add-keys     - retrieve GPG keys for sources
      --version      - print version and license info
    
    Options:
      --download-only|-d  - only download pkg on install/upgrade
      --simulate|-s       - show pkgs to be installed/upgraded
      --no-prompt|-y      - do not prompt during install/upgrade
      --prompt|-p         - always prompt during install/upgrade
      --reinstall         - re-install the pkg
      --ignore-excludes   - install/upgrade excludes
      --no-md5            - do not perform md5 check sum
      --no-dep            - skip dependency check
      --ignore-dep        - ignore dependency failures
      --print-uris        - print URIs only, do not download
      --show-stats|-S     - show download statistics
      --config|-c []      - specify alternate slapt-getrc location
      --remove-obsolete   - remove obsolete packages
      --retry []          - specify number of download retry attempts
      --no-upgrade        - install package, do not attempt to upgrade

  6. #16
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Okay i'll take a look when I get home

  7. #17
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006
    Posts
    1,031

    Default

    Quote Originally Posted by pureh@te View Post
    I tried that guys fix because muts wanted me to gather all the fixes in one place on the wiki but the add keys flag does not work and its not listed under slapt get help so I can only assume it doesnt work. The author of that post needs to make himself more clear and add some documentation if he wants it fixed in bt3 final.
    I must say that is a darn good photograph of yourself Hate.
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

  8. #18
    Junior Member
    Join Date
    Oct 2007
    Posts
    25

    Default

    Quote Originally Posted by hawaii67 View Post
    Here's what I did to resolve this problem:

    edit file /etc/slapt-get/slapt-getrc:

    comment out all "SOURCE" entries to become this:
    #SOURCE=..........
    #SOURCE=...........

    and append:

    SOURCE=..............


    Works fine with me...............................

    But i used the cmd==== #slapt-get --dist-upgrade --no-md5
    Works for me also thanks alot

  9. #19
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I found the problem dr.green. i was using my slackware 12.0 test and I thought I had the newest version of slapt get because its 0.9.12 but it seems the bt3 version is 0.9.12a . S0 now I am testing the fix and will post it in the apropriate place with due credit to the author

    Edit still does not work
    bt ~ # slapt-get --add-keys
    Retrieving GPG key [ftp://ftp.slackware.com/pub/slackwar...2.0/]...Cached
    GPGME: Invalid crypto engine
    GPG key could not be imported.
    Retrieving GPG key [http://software.jaos.org/slackpacks/12.0/]...Cached
    GPGME: Invalid crypto engine
    GPG key could not be imported.
    bt ~ # slapt-get --update
    Retrieving package data [ftp://ftp.slackware.com/pub/slackwar...2.0/]...Cached
    Retrieving patch list [ftp://ftp.slackware.com/pub/slackwar...2.0/]...Cached
    Retrieving checksum list [ftp://ftp.slackware.com/pub/slackwar...2.0/]...Cached
    Retrieving checksum signature [ftp://ftp.slackware.com/pub/slackwar...2.0/]...Cached
    Verifying checksum signature [ftp://ftp.slackware.com/pub/slackwar...e-12.0/]...Not Verified
    Retrieving package data [http://software.jaos.org/slackpacks/12.0/]...Cached
    Retrieving patch list [http://software.jaos.org/slackpacks/12.0/]...Cached
    Retrieving checksum list [http://software.jaos.org/slackpacks/12.0/]...Cached
    Retrieving checksum signature [http://software.jaos.org/slackpacks/12.0/]...Cached
    Verifying checksum signature [http://software.jaos.org/slackpacks/12.0/]...Not Verified
    Sources failed to download, correct sources and rerun --update
    bt ~ #
    No i will edit the slap-getrc sources and see if that helps

  10. #20
    Junior Member
    Join Date
    Oct 2007
    Posts
    25

    Default

    btw where does the source go?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •