I have tested 4 laptop's two Lenovo T60 one T61 and one T42
================================================== ======
T60 was tested via USB HDD also works fine with ISO CD

Lenovo T60, Type 1951
Centrino Duo T5600 @ 1.83 Ghz
VGA Mobile Intel 945GM Express Chip
SoundMax Intergrated Digital Audio
DLink AirPlus XtremeG DWL-G650 - madwifi drivers


*compiz from boot crashes just after login, similar to
hxxp://forums.remote-exploit.org/showthread.php?t=10227
however after log out and login using kde then back to compiz it works i suspect the kde login deals with the xconf issues
see screenshot...cubez :-)

sound is not autoconfigured
================================================== =======
T60 was tested via USB HDD also works fine with ISO CD

Lenovo T60 Type 2008
Intel Core Duo
T2400@ 1.83Ghz
ATI Mobility Radeon X1300
SoundMax Intergrated Digital Audio
DLink AirPlus XtremeG DWL-G650 - madwifi drivers

This one sound is autoconfigured ok.
not sure why coz has also Sound MAx like above
================================================== =======

T61 only works VESA mode
kde and compix screen goes blank had to reboot (there is some instruction for key combination to press if screen goes black but it was really zooming past the screen couldn't catch it)

================================================== =======
T42 boots fine with ISO CD

didnt get time to test wireless etc but will do that and update.

================================================== =======
please note that all the T60/T61 don't have bluetooth so cant test that.