Hi,
This integrated audio chipset is used a lot on newer laptops but requires the latest alsa-driver-1.0.15 to work.
BT3beta has 1.0.14.

Greets.