Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Kismet does not run

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    5

    Default Kismet does not run

    Kismet fails to run on both live cd and USB

  2. #2
    Senior Member imported_spankdidly's Avatar
    Join Date
    Feb 2006
    Posts
    1,031

    Default

    very true. Edit the Kismet.conf file for your wifi card. Then type in the terminal

    kismet


    it works. Clicking the icon in the menu does not work.
    I felt like bending the bars back, and ripping out the window frames and eating them. yes, eating them! Leaping, leaping, leaping! Colonics for everyone! All right! You dumb*sses. I'm a mental patient. I'm *supposed* to act out!

  3. #3
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    Far as I know the newer versions of kismet do not have the start-kismet-ng script included even though it is obviously on the iso. I do not think it works correctly with the new versions so as spankdidly said just use:
    Code:
    kismet
    Μολὼν λαβέ - Great spirits encounter heavy opposition from mediocre minds.

  4. #4
    Member imported_anubis2k7's Avatar
    Join Date
    Jun 2006
    Posts
    115

    Default

    As stated previously, to get it to work, you have to edit the kismet.conf file:

    #> cd ..
    #> nano /usr/local/etc kismet.conf

    Find the following line:

    source=none,none,addm

    Comment it out. For me, i'm using an atheros based card (DWL-G630), so I added the following line of code:

    source=madwifi_ag,wifi0,madwifi

    This "source" code is entirely dependent on which card you are using. Code for other kinds of cards can be found at this link:

    http://www.wi-fiplanet.com/tutorials...le.php/3595531

    Anywayz, save the file, run kismet, should work now.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    7

    Default

    Hi guys,

    Been trying to get kismet to run all day on my ubiquiti SRC but without any luck. Ive done all the usual reading and googling, found the answer to my problems but I just can seem to get it working.

    In the kismet.conf, ive tried editing the source line to:
    source=madwifi_ag,ath0,madwifi (as mentioned above)
    source=madwifi_g,ath0,madwifi
    source=madwifing_g,ath0,madwifi
    source=madwifi_ag,wifi0,madwifi
    etc, all without any luck. I always get the Fatal: no packsources enabled error.

    Could anyone point me in the right direction here, this atheros card is still new to me and i cant work out these madwifi drivers lol

    Cheers,
    James

  6. #6
    Jenkem Addict imported_wyze's Avatar
    Join Date
    Jul 2007
    Posts
    1,543

    Default

    Well it seems I've had the opposite problem... kismet won't die and the only way to kill it is to logout / back in
    dd if=/dev/swc666 of=/dev/wyze

  7. #7
    Member imported_anubis2k7's Avatar
    Join Date
    Jun 2006
    Posts
    115

    Default

    can you get airodump to work?

    that's generally where I start when i am troubleshooting a card.

    does your card work with kismet on BTv2? BTv1?

    if the answer is no to these questions, you might have a HW error with ur card....

  8. #8
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    7

    Default

    Yea i can run airodump, been doing it all night I can also inject with my card and surf the internet fine. It just seems to be that line in the configuration file is stoppin kismet from loading. Maybe its just me, but ive tried numerous times with different variations.

    Unfortunately, this card wouldn't boot under BT 2, so i was sooooooo relieved when it did on BT 3 lol. But like i have said, its working fine for everything else, just not kismet. I know i just need to get that line sorted and it will all be working again!

    Cheers

  9. #9
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    9

    Default

    my threads are in the wrong order

  10. #10
    Just burned his ISO l3g10n's Avatar
    Join Date
    Feb 2010
    Posts
    13

    Default

    Quote Originally Posted by swc666 View Post
    Well it seems I've had the opposite problem... kismet won't die and the only way to kill it is to logout / back in
    Are you exiting kismet by press Shift q?
    I only have this problem when I use CTRL C to exit out of kismet.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •