Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: problem when starting startx on notebook

  1. #1
    Just burned his ISO
    Join Date
    Sep 2007
    Posts
    4

    Default problem when starting startx on notebook

    when i start backtrack, it boots normal, then i log in.

    when i type startx now i get a error message telling me
    Code:
    (==)Log file: "/var/log/Xorg.0.log" Time: Fri Dec 14 14:11:22 2007
    (==)using config file : "/etc/X11/xorg.conf
    (II) Module already built in
    (EE)VESA(0): No matching modes
    (EE)Screen(s) found, but none have a usable configuration.
    
    Fatal server error:
    no screens found
    giving up.
    xinit: Connection reset by peer (errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server Error
    I get the same message when i type xconf and then startx =(
    I am using a HP Compaq 6715s notebook (screen resolution: 1280x800)
    I have the problem with Backtrack2 and with Backtrack 3, too.

    Can anyone help?

    greets elemmakil

  2. #2
    Member
    Join Date
    Mar 2007
    Posts
    204

    Default

    I get the same error when trying to boot on a HP desktop D530 SFF.

  3. #3
    Just burned his ISO
    Join Date
    Nov 2007
    Posts
    24

    Default

    You need to go into your BIOS and see what your display settings (or something that sounds simliar to that) are. And make sure they are set high enough.

    It should tell you in KB and see if it will let you set it higher.

  4. #4
    rimoka87
    Guest

    Default

    i have the same problem, but what it said is:
    server is already active for display 0
    If this server is no longer running, remove /tmp/ .X0-lock and start again.

  5. #5
    Just burned his ISO
    Join Date
    Sep 2007
    Posts
    4

    Default

    mhhh i have to install ati drivers on every startup then it works =)

  6. #6
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    could try

    Code:
    xconf
    Before startx

  7. #7
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    11

    Default

    I have the same problem.

    Quote Originally Posted by FockeWulf View Post
    You need to go into your BIOS and see what your display settings (or something that sounds simliar to that) are. And make sure they are set high enough.

    It should tell you in KB and see if it will let you set it higher.
    Tried looking for something like that but didn't find anything.

    I also entered xconf before startx but I keep getting the same error!

    I can run it in VESA mode or something like that though, chosen from the option menu before linux starts loading.

    I got a Toshiba Pro P200 laptop.

  8. #8
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    1

    Default

    [quote=elemmakil;56820]when i start backtrack, it boots normal, then i log in.

    when i type startx now i get a error message telling me
    Code:
    (==)Log file: "/var/log/Xorg.0.log" Time: Fri Dec 14 14:11:22 2007
    (==)using config file : "/etc/X11/xorg.conf
    (II) Module already built in
    (EE)VESA(0): No matching modes
    (EE)Screen(s) found, but none have a usable configuration.
    
    Fatal server error:
    no screens found
    giving up.
    xinit: Connection reset by peer (errno 104): unable to connect to X server
    xinit: No such process (errno 3): Server Error
    I get the same message when i type xconf and then startx =(
    I am using a HP Compaq 6715s notebook (screen resolution: 1280x800)
    I have the problem with Backtrack2 and with Backtrack 3, too.

    Can anyone help?

  9. #9
    Just burned his ISO
    Join Date
    Jan 2008
    Posts
    11

    Default

    ..........

  10. #10
    Just burned his ISO GileraGFR's Avatar
    Join Date
    Feb 2007
    Posts
    14

    Default

    I got the same error about not having a useable configuration and also have widescreen at 1280x800 res.

    Not sure if it'll work for you but i edited my xorg.conf to:

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"
    EndSection

    Section "Monitor"
    VertRefresh 43.0 - 60.0
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    HorizSync 28.0 - 51.0
    Option "DPMS" "true"
    EndSection

    Section "Device"
    BusID "PCI:1:0:0"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "RenderAccel" "True"
    Option "VideoOverlay" "on"
    Option "OpenGLOverlay" "off"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    ....

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •