Results 1 to 3 of 3

Thread: Question about loading the Intel Pro Wireless 3945 Drivers

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    2

    Default Question about loading the Intel Pro Wireless 3945 Drivers

    As stupid as this may sound it is a serious question. While it may be obvious to Linux users I am a Windows user and am very unfamiliar with Linux so at the risk of being relentlessly ridiculed i am going to ask this question anyway.

    Why is it that I must manually load my drivers from a command prompt every time I start Backtrack even though I have it installed on the Hard Drive?

    Why doesn't it just see the hardware and load the driver like Windows?

    I am going to read through all the noob area as soon as possible and I hope to start using Linux much more. This is in part due to my disappointment with Vista. I figure my next computer will either be a Mac or I will use Linux. I guess it just depends on if I can get the hang of Linux or not.

    It does seem though that maybe it is not good for general users or for everyday use if you have to manually load drivers and stuff from the command prompt instead of the OS doing this manually.

    Anyway thanks for the clarification and go easy on me I may be a Windows Dork and a Linux noob, but I am going to read all the Slackware books I can and hopefully soon I can rid myself of this beast they call Vista!

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    this is not the case with all drivers. For some reason it how it was made. You can easily remedy the situation by loading the drivers via a startup script. The one I always use is /etc/rc.d/rc.M . open that with kwrite or something and then add a line to load your drivers.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    2

    Default Thanks

    Thanks for the tip. I will take advantage of this. It is good to know that not all drivers will be this way. I have ordered a DLink PC Card with the atheros chipset that should be in tommarow. I Hope it will work much better. I work for a fairly small company of about 22 peeps. We use WEP to secure our Wi-Fi network. I have tried to switch us to WPA-PSK or even a RADIUS server but my boss does not see the need. I hope to change his mind soon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •