Results 1 to 10 of 10

Thread: Dual boot windows - backtrack with a protected MBR

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    3

    Default Dual boot windows - backtrack with a protected MBR

    Hi guys,

    Although I usually work with linux fedora on my home pc I have only minimal experience with linux operating systems except for user applications.

    I got a company portable yesterday and wanted to try out this backtrack 2 since I used Auditor in the past a couple times. I got windows installed, and installed BT2 as well on /dev/hda3, /dev/hda2 is a linux swap and /dev/hda1 is the windows NTFS. But liloconfig won't do anything, it simply gets booted to windows at all times. I presume the MBR is protected so lilo can't write to it, however I don't know how to can confirm this except for the error I get when calling lilo :
    Fatal : creat /boot/map~: Read-only file system

    The portable in question is a Dell Latitude D600 if that's important and I've already check the BIOS but there's nothing usefull in there either.

    any help is greatly appreciated!

  2. #2
    Junior Member sin_gage's Avatar
    Join Date
    Oct 2007
    Posts
    64

    Default

    http://forum.remote-exploit.org/show...l+boot+windows

    what is the order in which you have install different OS?
    :cool:" i had rather be hated for wat i am than to be loved for wat i am not ......":p

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    3

    Default

    order :
    windows (clean install yesterday).
    BT2

    and yes my lilo.conf is up-to-date and triple checked.
    using lilo -V instead of lilo give me the following:

    Reading boot sector from /dev/hda
    Fatal : Creat /boot/map~: Read-only file system.

    I've already tried unmounting & re-mounting :

    mount [enter]
    cd / [enter]
    umount /mnt/hda1 [enter]
    umount /mnt/hda3 [enter]
    mkdir /mnt/bt [enter]
    mount /dev/hda3 /mnt/bt [enter]
    mkdir /mnt/bt/boot [enter]
    mount /dev/hda1 /mnt/bt/boot [enter]
    cp /boot/vmlinuz /mnt/bt/boot/ [enter]
    -->cp : cannot create regular file '/mnt/bt/boot/vmlinuz': Read-only file system

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    The order does not matter. If your sure windows is there and bt is there then boot your live cd and use the chroot command to change into your root install directory

    bt~#chroot /mnt/sda3(or whatever) /bin/bash

    then bt~#nano /etc/lilo.conf

    Do a little searching on this site For "lilo.conf" for example and you will find all kinds of examples of what you config should look like.

    Reboot and presto, Bobs your uncle.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    21

    Default

    The problem is he is not writing to the MBR at all, so editing the lilo config doesn't sound like it will do much good... This windows XP or vista?

    Try installing the bootloader to the BT partition, make sure it doesn't have a problem doing that.

    With vista it is actually pretty easy to use it's boot loader to make a linux option to boot the BT partition. I would have to look on how to do it in XP, if it can be done at all. I am not 100% how to modify it in linux, but i know the Partition Magic cds have a way to turn off the MBR protection, and double check the BIOS under virus protection, sometimes there is a MBR security feature in there.

    Z

  6. #6
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    Did you try running "liloconfig" in expert mode and re-write the mbr from there, adding the OS's as you go through the "wizard"?

    I have known the standard hdd installer to inexplicably fail writing the mbr, when there is no "mbr protection" of any kind involved, but then work on the 2nd attempt, or from liloconfig.
    Worth a go.....?

    Failing that, take a look at your mbr with some of the excellent mbr tools on Hirens cd.

  7. #7
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    9

    Default

    i'm not sure about vista, but if this is XP and you want to dual boot, you'd have to make a file containing the first 512 bytes of the boot sector of bt... then, put that file into the "C:" directory and change the boot.ini file to have a selection to point to that file. i'm still a noob so this might be missing something. i'm sure you could find it with a general web search.

  8. #8
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I have installed bt on various xp and vista machines with no mbr problems.

  9. #9
    Junior Member
    Join Date
    Nov 2007
    Posts
    97

    Default

    Quote Originally Posted by purehate View Post
    I have installed bt on various xp and vista machines with no mbr problems.
    On this laptop I currently have BT, XP-Pro, Vista Ultimate, and Gentoo. Not a single MBR problem. I editied lilo.conf accordingly, issued lilo -v, and hey presto.

    It's unlikely to be an actual MBR problem.

  10. #10
    Just burned his ISO lock_n_loll's Avatar
    Join Date
    Jul 2007
    Posts
    21

    Default

    liloconfig is the best solution for writing linux loader at MBR
    Just Try liloconfig with simple menu or expert menu ..but i think u should try expert menu
    for your problem.
    Damn Am I Late ?
    Mitsubishi AMITY XP P166 MMX 32M HD 6 GB Linksys WPC11 v4 FreeBSD 7.0 + BT2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •