Results 1 to 6 of 6

Thread: manually starting Atheros Card in Backtrack 2

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    5

    Default manually starting Atheros Card in Backtrack 2

    I have been searching forums and posts and highways for the answer.

    How do I start my Atheros card (acer aspire 5050 with 5005g chipset) manually in Backtrack 2?

    I have read that the driver is already on the live CD so there is no need to patch it etc...
    well how do i inject it, or what ever i need to do so it loads and then locates my card?

    if i type iwconfig it says
    " lo no wireless extensions
    eth0 no wireless extensions "

    if i type ifconfig -a it says
    eth0 .....hwaddr 00:1b:24:32:93:90 (tons of stuff)
    lo link encap: Local loopback (blaaah)

    Anyway it seems like its an easy question yet no one really answers it in the threads etc.

    Another way to ask this is....how do i load the madwifi driver in backtrack 2 so it loads my atheros wifi card???
    HELP ME PLEASE?!?!

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    bt~#modprobe ath_pci

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    5

    Default

    Thanks Tryin it now- report back in a bit

  4. #4
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    5

    Default

    Yeah that command doesnt do anything.

    bt ~# modprobe ath_pci
    bt ~#

    then i go to look and iwconfig still says no wireless found etc
    and ifconfig -a says eth0 and lo are active...
    is my eth0 only my LAN?

    anything else i can try? I boot with bt irqpoll...should i try that command after i do something first...i dont know. Let me know

  5. #5
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Do you have a hard drive install? Maybe you should just reinstall the madwifi drivers.

    I believe the drivers are located in the /usr/src/drivers folder. Check whether You have them.

  6. #6
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    5

    Default

    I am booting off the Live CD.
    How do i know what driver to get etc. I have the atheros 5005g chipset. I very new to linux (obviously).

    If the driver is in usr/scr/driver do i just open the file? anyway I just ask these questions because it takes about 10mins to boot into BS2 on here . it tries to load the audio file for ever till it skips it and finally loads. so its annoying to go back and forth.
    anyway ill look for the file. otherwise ill be back with more questions!! Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •