Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Compiz-Fusion Demo

  1. #11
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Still no worky however my mplayer is working much better so the upgrade helped. now its in english but i seem to be missing some codecs
    Code:
    pureh@te ~ # mencoder out.ogg -o movie.avi -ovc lavc -oac lavc
    MEncoder dev-SVN-r25196-4.1.2 (C) 2000-2007 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz (Family: 6, Model: 15, Stepping: 6)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    
    success: format: 0  data: 0x0 - 0xa223bbd
    [Ogg] stream 0: video (Theora v3.2.0), -vid 0
    [Ogg] stream 1: audio (Vorbis), -aid 0
    Ogg file format detected.
    VIDEO:  [theo]  1024x768  24bpp  20.000 fps    0.0 kbps ( 0.0 kbyte/s)
    [V] filefmt:18  fourcc:0x6F656874  size:1024x768  fps:20.00  ftime:=0.0500
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 22050 Hz, 2 ch, s16le, 172.0 kbit/24.37% (ratio: 21497->88200)
    Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis decoder)
    ==========================================================================
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    [theora @ 0x878e4f0]Missing extradata!
    Could not open codec.
    VDecoder init failed :(
    Opening video decoder: [theora] Theora/VP3
    VDec: vo config request - 1024 x 768 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
    videocodec: libavcodec (1024x768 fourcc=34504d46 [FMP4])
    Selected video codec: [theora] vfm: theora (Theora (free, reworked VP3))
    ==========================================================================
    [mp2 @ 0x878e4f0]bitrate 224 is not allowed in mp2
    Couldn't open codec mp2, br=224.
    
    Exiting...
    pureh@te ~ #
    The ffmpeg command worked fine i just want to add music to either the .ogg file before I convert it or to the .avi after I convert it. I guess I could take it to the windows station and do it but I would like to do it all here on my lappy.

  2. #12
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    http://www.afreecodec.com/linux/161/...pack/download/

    or

    Code:
    slapt-get --install all
    Install them and it should work

  3. #13
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Do I need to prefix usr or is it a installer? I obviously dont have it yet however I thought I'd ask.

  4. #14
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    just use slapt-get

    Code:
    slapt-get --install all
    Now you slackware 12 its worth getting gslapt as well because it lets you search for packages with keywords etc

  5. #15
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Nope same error. Am I using the right arguments with the command
    mencoder out.ogg -o movie.avi -ovc lavc -oac lavc

  6. #16
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Run it through lives and add some sound first sorry thats your error

  7. #17
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    Thats my point I do not no how to do that. I have a wma file and a .ogg file so how do i combine the two to make a .avi with sound?

  8. #18
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Code:
    slapt-get --install lives
    Now run it and open the .ogg file and wait about 30 mins or so. Go through the menu adding audio, effects ETC and then file >> encode.

    This should rewrite your .ogg file with a new vid with sound, then mencode that file and you are done.

  9. #19
    Developer
    Join Date
    Mar 2007
    Posts
    6,126

    Default

    When I try to run lives it says my hw:0 playback device is in use and then it gives me a jack error

  10. #20
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Code:
    killall -9 artsd
    And try again

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •