Hey folks:

Been a while... well I tried to install BT to a HDD with no other OS' and got the error in the title... it took me a while and some help to figure it out... but here is the whole walk through of everything i did...i hope this helps you:

**** Following these instructions WILL wipe your hard drive of all data ****

fdisk /dev/hda [enter]
n [enter]
p [enter]
1 [enter]
[enter]
+50M [enter]
n [enter]
p [enter]
2 [enter]
[enter]
+512M [enter]
n [enter]
p [enter]
3 [enter]
[enter]
[enter]
a [enter]
1 [enter]
t [enter]
2 [enter]
82 [enter]
p [enter]
w [enter]

At this point you should not see any errors... if it asks you reboot, please do.
you should see
The partition table has been altered!
Calling ioctl() to re-read partition table.
Syncing disks.

Next i typed:
mkfs.ext3 /dev/hda1 [enter]
mkfs.ext3 /dev/hda3 [enter]
cd /tmp [enter]
mkdir boot [enter]
mkdir bts [enter]
mount /dev/hda1 boot [enter]
mount /dev/hda3 bt2 [enter]

Then i went into BT by typing
startx [enter]

When in the system i went to the KDE MENU

KDE > System > Back Track Installer
set my settings:

Source: = /boot
Install to: = /tmp/bt2
Write MBR to: = /dev/hda

Chose REAL
clicked INSTALL

Mine seemed like it hung at 45% and 81%

when it was over i did what it said...
I rebooted

But I was told quickly that my Hard Drive had no bootable partitions and there was a non-system disk.

So i rebooted using the Live CD

after booting using root and toor
After researching i tried to edit the lilo.config and then typed:
lilo -v [enter]

and I got this error:

Fatal: creat /boot/map~_ Read-only file system

No matter what i tried i couldn't get it to work...


A good buddy and i figured out (ok ok, actually he did most of the figuring...)

here is how we got it to work

from the shell

mount [enter]
cd / [enter]
umount /mnt/hda1 [enter]
umount /mnt/hda3 [enter]
mkdir /mnt/bt [enter]
mount /dev/hda3 /mnt/bt [enter]
mkdir /mnt/bt/boot [enter]
mount /dev/hda1 /mnt/bt/boot [enter]
cp /boot/vmlinuz /mnt/bt/boot/ [enter]
ls -l /mnt/bt
and you should see things like
bin
etc
dev
root
usr
etc and more....
now type:

cd / [enter]
mount -t proc proc /mnt/bt/proc [enter]
mount -o bind /dev /mnt/bt/dev [enter]
chroot /mnt/bt /bin/bash [enter]
nano /etc/lilo.conf [enter]
Make sure the lilo.conf says this:

boot = /dev/hda
prompt
timeout = 20
change=rules
reset
vga=0x317
image = /boot/vmlinuz
root = /dev/hda3
initrd = /boot/splash.initrd
label = back|track
read-only

ctrl+x
save of course
now type:
lilo -v [enter]

reboot [enter]

This worked, i rebooted and was into BT with no problems.

I hope this helps you as much as it helped me.