Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: SQLite update

  1. #1
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Question SQLite update

    Hi i have installed bt2 to my hard drive on an old sony laptop i am trying to update sqlite but when i do this command it wont do anything just finishes straight away and it just stores an empty file to root

    curl -O XXX://XXX.sqlite.org/sqlite-3.4.0.tar.gz

    also if you type this into web

    XXX.sqlite.org/sqlite-3.4.0.tar.gz

    Document Not Found
    The document /sqlite-3.4.0.tar.gz is not available on this server

    do you think its down or is there another way to update accept this

    curl -O XXX://XXX.sqlite.org/sqlite-3.4.0.tar.gz
    tar xvzf sqlite-3.4.0.tar.gz
    cd sqlite-3.4.0
    ./configure --prefix=/usr/local
    make

    I have looked but everyone seems to use same method maybe i am missing a new way or something i had to star out url as i have not posted enough yet lol
    Thanks guys i am such a bitch ass noob

  2. #2
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    try this instead

    Code:
    bt~#wget -r http://www.slacky.eu/repository/slackware-11.0/database/sqlite/3.4.0/sqlite-3.4.0-i486-1sl.tgz
    then
    Code:
    bt~#installpkg sqlite-3.4.0-i486-1sl.tgz

  3. #3
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default

    You the man purehate sorry to pi** you off with all questions

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Quote Originally Posted by dapirates1 View Post
    You the man purehate sorry to pi** you off with all questions
    Who said I was pissed. I try to help where I can so that when i need help my karma is good.

  5. #5
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default

    Hi purehate i followed the steps you provided
    wget -r xxx://xxx.slacky.eu/repository/slackware-11.0/database/sqlite/3.4.0/sqlite-3.4.0-i486-1sl.tgz

    bt ~ # installpkg sqlite-3.4.0-i486-1sl.tgz
    Installing package sqlite-3.4.0-i486-1sl...
    PACKAGE DESCRIPTION:
    sqlite: Sqlite (Small C library that implements a SQL database engine)
    sqlite:
    sqlite: SQLite is a small C library that implements a self-contained,
    sqlite: embeddable, zero-configuration SQL database engine.
    sqlite: The SQLite distribution comes with a standalone command-line
    sqlite: access program (sqlite) that can be used to administer
    sqlite: an SQLite database and which serves as an example
    sqlite: of how to use the SQLite library.
    sqlite:
    Executing install script for sqlite-3.4.0-i486-1sl...

    bt ~ #sqlite3 -version it shows 3.3.7 do i need to reboot and will it include fix from balding_parrot 's post here Solution to sqlite Compile problems to allow use of Aircrack-ng 1 Dev r540 or above i want to try -=Xploitz=- VIDEO: Vol. #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases i have just got sqlite-3.4.0.lzm
    from balding_parrots post but how do i install this i am a confused giza at the best of times lol

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    http://shamanvirtuel.googlepages.com....ShamanVirtuel


    I forgot about the patch sorry. OK Im doing this from memory because I'm at work so bear with me.

    Down load shamens updater above to your root directory

    then make it excecutable by doing this

    bt~#chmod 777 (file name here)
    then run the file
    bt~#./(filenamehere)
    after it installs you should have a icon on your desktop. Choose sqlite patch and install. Then you can update to whatever aircrack you want. Make sure you choose something in the module creation at the bottom. No module should be fine for right now

  7. #7
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default

    I did what you said i open aircrack updater v2.0 it shows me as sql lite 3.3.7 i have an option to install 3.4.0 then next to it a little box ticked BT2.0 patch i chose that to and choose no module creation then click install sqlite 3.4.0 after a while it says creation of sqlite 3.4.0 libs module for bt2.0 done saved in /root/aircrackmodules/ installation of sqlite 3.4.0 libs done update finished

    then i choose to update aircrack to latest dev 1.0 all installs but i have no airolib-ng command sorry to hear you are at work btw

    so i think sqlite did not install with the first links you gave me as i am still saying

    bt ~ # sqlite3 -version
    3.3.7
    bt ~ #
    this was so easy to do on my other laptop

  8. #8
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Default

    I just found sqlite-3.4.0.tar.gz here :
    xxxx://xxx.slacky.eu/repository/slackware-11.0/database/sqlite/3.4.0/src/
    think i will start from scratch thanks for your time purehate

  9. #9
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007
    Posts
    705

    Default

    Replace the old sqlite app with the new one you compiled and it will show the correct version....

    also http downloads are down but cvs is still up for sqlite.org
    Μολὼν λαβέ - Great spirits encounter heavy opposition from mediocre minds.

  10. #10
    Junior Member dapirates1's Avatar
    Join Date
    Nov 2007
    Posts
    88

    Smile

    I have got it installed all working now thanks for the advice but i have caused another problem now as kismet wont fire up any more it did before is there a reason for this does i.e needs updating or have i just f***ed it up this is what it says when i try to run kismet now

    Server options: none
    Client options: none
    Starting server...
    Waiting for server to start before starting UI...
    Suid priv-dropping disabled. This may not be secure.
    No specific sources given to be enabled, all will be enabled.
    Enabling channel hopping.
    Enabling channel splitting.
    FATAL: No packsources were enabled. Make sure that if you use an enablesource line that you specify the correct sources.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •