I just purchased a Alfa AWUSO36H USB wireless card which contains an rtl8187l chipset.

On both Kali and BT R3 i am experiencing the same problem, slow speed and random disconnections. The detail that i noticed the most is the fact that the iwconfig tool is reporting that there are 3000+ Tx excessive retries when im downloading a 25mb file. The wifi connection then drops and will not allow me to reconnect until i have rebooted. Below are some information outputted by the system that may help in diagnosing the problem.

Below is airmon-ng:
Code:
root@kali-laptop:~# airmon-ng
Interface	Chipset		   Driver
wlan1		Realtek RTL8187L   rtl8187 - [phy2]
Below is the system information during the download of a file:
Code:
root@kali-laptop:~# iwconfig wlan1 && ifconfig wlan1
wlan1     IEEE 802.11bg  ESSID:"PIKE168"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 7C:4C:A5:1F:6A:F5   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-15 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2037  Invalid misc:48   Missed beacon:0
------------------------------------------------------------------------
wlan1     Link encap:Ethernet  HWaddr 00:c0:ca:6d:9d:7a  
          inet addr:192.168.0.8  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:caff:fe6d:9d7a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7940 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5073 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:11322396 (10.7 MiB)  TX bytes:462625 (451.7 KiB)
After a while the card will disconnect from the AP and will be unable to reconnect unless i reboot. Below is the information after a disconnect:
Code:
root@kali-laptop:~# iwconfig wlan1 && ifconfig wlan1
wlan1     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
------------------------------------------------------------------------          
wlan1     Link encap:Ethernet  HWaddr 00:c0:ca:6d:9d:7a  
          inet addr:192.168.0.8  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:caff:fe6d:9d7a/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:14725 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9201 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:21555532 (20.5 MiB)  TX bytes:833677 (814.1 KiB)
I then used lsmod to see which drivers were being used and this provided me with:
Code:
Module                  Size  Used by
rtl8187                31077  0 
mac80211              287461  1 rtl8187
cfg80211              123887  2 mac80211,rtl8187
eeprom_93cx6           12641  1 rtl8187
usbcore               109555  5 uvcvideo,rtl8187,rts5139,ehci_hcd,xhci_hcd
I then used modinfo to find out about these modules:
Code:
filename:       /lib/modules/3.7-trunk-686-pae/kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko
description:    RTL8187/RTL8187B USB wireless driver
vermagic:       3.7-trunk-686-pae SMP mod_unload modversions 686 

filename: /lib/modules/3.7-trunk-686-pae/kernel/net/mac80211/mac80211.ko description: IEEE 802.11 subsystem depends: cfg80211 vermagic: 3.7-trunk-686-pae SMP mod_unload modversions 686 parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int) parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int) parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int) parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
filename: /lib/modules/3.7-trunk-686-pae/kernel/net/wireless/cfg80211.ko description: wireless configuration support depends: rfkill vermagic: 3.7-trunk-686-pae SMP mod_unload modversions 686 parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp) parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)