Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Post Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Hi, I am new to this forum and to linux, so if I post with bad etiquette or anything, I apologize.

    Alright, here is my problem. I am running Backtrack 5 r3 fully installed on my hdd, with a TP-link TL-WN722N USB wireless card. I know that Backtrack detects my device because it shows up as 'Atheros AR9271' when I run lsusb. However, when I open wicd, it shows that there are no networks available, and when I run iwconfig I get:

    lo no wireless extensions.
    eth0 no wireless extensions.

    When I run airmon-ng I get:

    Interface Chipset Driver

    but it doesn't show anything else. I have the AR9271 driver. Also, my wireless config file is empty. I am pretty sure that is part of the problem, but I think there may be more to it as well. Any help is greatly appreciated. Thanks!
    Last edited by TomGauss; 03-07-2013 at 02:25 PM.

  2. #2
    Just burned their ISO C00m4nd0's Avatar
    Join Date
    Feb 2013
    Posts
    6

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Quote Originally Posted by TomGauss View Post
    Hi, I am new to this forum and to linux, so if I post with bad etiquette or anything, I apologize.

    Alright, here is my problem. I am running Backtrack 5 r3 with a TP-link TL-WN722N USB wireless card. I know that Backtrack detects my device because it shows up as 'Atheros AR9271' when I run lsusb. However, when I open wicd, it shows that there are no networks available, and when I run iwconfig I get:

    lo no wireless extensions.
    eth0 no wireless extensions.

    When I run airmon-ng I get:

    Interface Chipset Driver

    but it doesn't show anything else. I have the AR9271 driver. Also, my wireless config file is empty. I am pretty sure that is part of the problem, but I think there may be more to it as well. Any help is greatly appreciated. Thanks!
    You maybe need to do a:
    usb_modeswitch -v xxxx -p xxxx <---- where xxxx replace with numbers from lsusb ex. -v --->>12d1:1c35 <--- -p
    your command will be:
    Code:
    root@bt:~# usb_modeswitch -v 12d1 -p 1c35
    Use your numbers for vendor and product ID.

    Than try:
    Code:
    root@bt:~# ifconfig
    If you can see your extension, something like wlan0 or wlan1...etc
    Then:
    Code:
    root@bt:~# airmon-ng start wlan0 <---- your interface
    Let me know if that helps.

  3. #3
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Thanks for the help! I Tried what you said and this is what happened:

    Code:
    root@bt:~# lsusb
    Bus 011 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 010 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 010 Device 002: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
    Bus 010 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 008 Device 003: ID 046d:c05a Logitech, Inc. Optical Mouse M90
    Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@bt:~# usb_modeswitch -v 0cf3 -p 9271
    
    Looking for default devices ...
     Found devices in default mode or class (1)
    Accessing device 003 on bus 010 ...
    Using endpoints 0x01 (out) and 0x82 (in)
    Not a storage device, skipping SCSI inquiry
    
    USB description data (for identification)
    -------------------------
    Manufacturer: ATHEROS
         Product: USB2.0 WLAN
      Serial No.: 12345
    -------------------------
    Warning: no switching method given.
    -> Run lsusb to note any changes. Bye.
    
    root@bt:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 94:de:80:21:35:ce  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:75 Base address:0x8000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:33 errors:0 dropped:0 overruns:0 frame:0
              TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:2273 (2.2 KB)  TX bytes:2273 (2.2 KB)

    It didn't show up as wlan0 or anything when I ran ifconfig as you can see. Do I need to edit my wireless config file and add it or something?

    EDIT:

    I don't know if this is useful information or not, but I thought I had better include it.
    The wireless card is a USB 2.0 device (as are my mouse and keyboard), and when I am on Windows the wireless card won't work in a USB 3.0 port.
    However, when I am on backtrack none of the USB 2.0 ports work; it doesn't recognize my mouse, keyboard, or wireless card unless they are plugged
    into one of the USB 3.0 ports. So I am thinking this whole thing could have something to do with the level of compatibility my wireless card has with USB 3.0.
    I know nothing about that, though. I am going to look for some information about it, and I will post back here if I find anything.
    Last edited by TomGauss; 03-10-2013 at 12:06 AM. Reason: Additional Information

  4. #4
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Update:
    Alright, so I learned that my problem may be that I needed to either install some drivers that I already had, or get some drivers that I didn't have an then install them. So I got the compat wireless drivers from here: http://drvbp1.linux-foundation.org/~...ompat-drivers/
    and ran

    Code:
    tar -xf /root/compat-drivers-3.9-rc2-2-su.tar.bz2 
    cd compat-drivers-3.9-rc2-2-su 
    make 
    make install 
    make unload 
    reboot
    which ran through all of the install info. Then I ran a modprobe for two of the ath9k drivers

    Code:
    modprobe ath9k_htc
    modprobe ath9k
    but nothing happened. I don't know if this is whats supposed to happen if everything is running smoothly or not.
    Then I rebooted, and ran service networking start, and service wicd start, but when I opened wicd there were no connections available.
    and when I run airmon-ng it still doesn't recognize my device. It just gives the same output I posted above when I ran it before.

    What am I doing wrong?

  5. #5
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Quote Originally Posted by TomGauss View Post
    Update:
    Alright, so I learned that my problem may be that I needed to either install some drivers that I already had, or get some drivers that I didn't have an then install them. So I got the compat wireless drivers from here: http://drvbp1.linux-foundation.org/~...ompat-drivers/
    and ran

    Code:
    tar -xf /root/compat-drivers-3.9-rc2-2-su.tar.bz2 
    cd compat-drivers-3.9-rc2-2-su 
    make 
    make install 
    make unload 
    reboot
    which ran through all of the install info. Then I ran a modprobe for two of the ath9k drivers

    Code:
    modprobe ath9k_htc
    modprobe ath9k
    but nothing happened. I don't know if this is whats supposed to happen if everything is running smoothly or not.
    Then I rebooted, and ran service networking start, and service wicd start, but when I opened wicd there were no connections available.
    and when I run airmon-ng it still doesn't recognize my device. It just gives the same output I posted above when I ran it before.

    What am I doing wrong?
    You need the firmware as well: http://wireless.kernel.org/download/htc_fw/1.3/

    You need the htc_9271.fw. Once downloaded, please copy it here: /lib/firmware/

    It should be seeing like this: /lib/firmware/htc_9271.fw

    Reboot, then see if it was loaded, if not, do it manually...Your iface might end up in wlan0 or wlan1..

  6. #6
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Thanks for the help! I got the firmware (which I guess I already had) and copied it into /lib/firmware,
    then rebooted and did exactly this:

    Code:
    root@bt:~# startx
    root@bt:~# service networking start
    networking stop/waiting
    root@bt:~# service wicd start
     * Starting Network connection manager wicd                              [ OK ] 
    root@bt:~# ifup
    ifup: Use --help for help
    root@bt:~# ifup wlan0
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright 2004-2009 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    SIOCSIFADDR: No such device
    wlan0: ERROR while getting interface flags: No such device
    wlan0: ERROR while getting interface flags: No such device
    Bind socket to interface: No such device
    Failed to bring up wlan0.
    root@bt:~# airmon-ng
    
    
    Interface	Chipset		Driver
    
    
    root@bt:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 94:de:80:21:35:ce  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:75 Base address:0x8000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:32 errors:0 dropped:0 overruns:0 frame:0
              TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:2201 (2.2 KB)  TX bytes:2201 (2.2 KB)
    
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    I don't know how to load the drivers manually, but I imagine that could be my problem.
    Thanks for explaining things!

  7. #7
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    First check what module was loaded (if any): lsusb -v

    Post it.

    Unplug the usb device and do this
    1. Remove the modules loaded by kernel ------> modprobe -rf ath9k ath9k_htc
    2. unblock all hard and soft locks (just in case)----> rfkill unblock all
    3. load modules ath9k and ath9k_htc -------------> modprobe ath9k ath9k_htc
    4. Plug the USB stick again.

    Then try to stop and then start networking services:----> /etc/init.d/wicd stop and then start

    Check with iwconfig to see if any interface shows up...

    Please post /etc/netwonk/interfaces and /etc/network/run/ifstate files.

    TRy wlan0 and wlan1...You do not know in which interface is your wifi device..Use ifconfig, not ifup please.

    Ifup will search for the /etc/network/interface file, reads it and configure the interfaces within the file according to the parameters in the same file..If wlan0 or wlan1 are not in there, you will end up configuring nothing or configuring an unexisting interfce.

    Refer to ifup manual (man ifup)..Use ifconfig to configure the interface and bring it up/down manually...

    Remember, it can be in wlan0 or wlan1.
    Last edited by maverik35; 03-13-2013 at 11:15 PM.

  8. #8
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Alright I got this far:
    I ran lspci -v and got this:

    http://pastebin.com/zFxLuag9

    but I am not sure which module I need to remove.

    I also ran lsusb -v because my wireless card is a USB device. I am not sure if that information is useful or not, but here it is.

    (It was too long to post here, so here is a link to paste bin)
    http://pastebin.com/W6k71Jmp

    here is the contents of /etc/network/interfaces

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    
    auto wlan0
    iface wlan0 inet dhcp
    There was not a directory called run in /etc/network. This is all that I have

    Code:
    root@bt:/etc/network# ls
    if-down.d  if-post-down.d  if-pre-up.d  if-up.d  interfaces
    Could my problem be that that directory doesn't exist? Or am I just looking in the wrong place? Also, which kernel module do I need to remove, and from where do I get the ath9k_htc module?
    Thanks for your help!

    EDIT: I posted this before I saw your edit, so I did exactly what you said and this is the result:

    Code:
    root@bt:~# modprobe -rf ath9k
    root@bt:~# modprobe -rf ath9k_htc
    root@bt:~# rfkill unblock all
    root@bt:~# modprobe ath9k
    root@bt:~# modprobe ath9k_htc
    root@bt:~# /etc/init.d/wicd stop
     * Stopping Network connection manager wicd                              [ OK ] 
    root@bt:~# /etc/init.d/networking stop
     * Deconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 1221
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright 2004-2009 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    Listening on LPF/eth0/94:de:80:21:35:ce
    Sending on   LPF/eth0/94:de:80:21:35:ce
    Sending on   Socket/fallback
    DHCPRELEASE on eth0 to 192.168.48.254 port 67
    send_packet: Network is unreachable
    send_packet: please consult README file regarding broadcast address.
                                                                             [ OK ]
    root@bt:~# /etc/init.d/wicd start
     * Starting Network connection manager wicd                              [ OK ] 
    root@bt:~# /etc/init.d/networking start
    Rather than invoking init scripts through /etc/init.d, use the service(8)
    utility, e.g. service networking start
    
    Since the script you are attempting to invoke has been converted to an
    Upstart job, you may also use the start(8) utility, e.g. start networking
    ^C
    root@bt:~# start networking
    start: Job is already running: networking
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    root@bt:~# ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device
    root@bt:~# ifconfig wlan1 up
    wlan1: ERROR while getting interface flags: No such device
    root@bt:~#
    Last edited by TomGauss; 03-16-2013 at 04:06 PM.

  9. #9
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Quote Originally Posted by TomGauss View Post
    Alright I got this far:
    I ran lspci -v and got this:

    http://pastebin.com/zFxLuag9

    but I am not sure which module I need to remove.

    I also ran lsusb -v because my wireless card is a USB device. I am not sure if that information is useful or not, but here it is.

    (It was too long to post here, so here is a link to paste bin)
    http://pastebin.com/W6k71Jmp

    here is the contents of /etc/network/interfaces

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    
    auto wlan0
    iface wlan0 inet dhcp
    There was not a directory called run in /etc/network. This is all that I have

    Code:
    root@bt:/etc/network# ls
    if-down.d  if-post-down.d  if-pre-up.d  if-up.d  interfaces
    Could my problem be that that directory doesn't exist? Or am I just looking in the wrong place? Also, which kernel module do I need to remove, and from where do I get the ath9k_htc module?
    Thanks for your help!

    EDIT: I posted this before I saw your edit, so I did exactly what you said and this is the result:

    Code:
    root@bt:~# modprobe -rf ath9k
    root@bt:~# modprobe -rf ath9k_htc
    root@bt:~# rfkill unblock all
    root@bt:~# modprobe ath9k
    root@bt:~# modprobe ath9k_htc
    root@bt:~# /etc/init.d/wicd stop
     * Stopping Network connection manager wicd                              [ OK ] 
    root@bt:~# /etc/init.d/networking stop
     * Deconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 1221
    killed old client process, removed PID file
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright 2004-2009 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    Listening on LPF/eth0/94:de:80:21:35:ce
    Sending on   LPF/eth0/94:de:80:21:35:ce
    Sending on   Socket/fallback
    DHCPRELEASE on eth0 to 192.168.48.254 port 67
    send_packet: Network is unreachable
    send_packet: please consult README file regarding broadcast address.
                                                                             [ OK ]
    root@bt:~# /etc/init.d/wicd start
     * Starting Network connection manager wicd                              [ OK ] 
    root@bt:~# /etc/init.d/networking start
    Rather than invoking init scripts through /etc/init.d, use the service(8)
    utility, e.g. service networking start
    
    Since the script you are attempting to invoke has been converted to an
    Upstart job, you may also use the start(8) utility, e.g. start networking
    ^C
    root@bt:~# start networking
    start: Job is already running: networking
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    root@bt:~# ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device
    root@bt:~# ifconfig wlan1 up
    wlan1: ERROR while getting interface flags: No such device
    root@bt:~#
    Type: lsmod | grep -i ath9k

    or lsmod and look for the ath9k and ath9k_htc

    Post the output, please.

    If they are loaded do as I posted:
    Unplug the usb device and do this
    1. Remove the modules loaded by kernel ------> modprobe -rf athk9k ath9k_htc
    2. unblock all hard and soft locks (just in case)----> rfkill unblock all
    3. load modules ath9k and ath9k_htc -------------> modprobe ath9k_htc ------->Just load the ath9k_htc
    4. Plug the USB stick again.

    YOU need to UNPLUG the wifi device first, then follow steps..
    Check with iwconfig to see if any interface shows up...

    If still nothing, please do this:
    open up a terminal and do this: cat /boot/config-"your kernel version" | grep -i config_ath ------> Check this parameters:
    CONFIG_ATH_COMMON=m
    CONFIG_ATH9K_HW=m
    CONFIG_ATH9K_COMMON=m
    CONFIG_ATH9K_HTC=m

    They must be enabled (=m), use nano to edit and change the file if are not enabled:
    nano /boot/config-"your kernel version"

    Then change parametes accordingly. Save (Ctrl+O) and Exit (Ctrl+X).

    Reboot.

    Repeat steps above (unplug, steps 1-4, plug back in)
    Last edited by maverik35; 03-17-2013 at 07:01 PM.

  10. #10
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    7

    Default Re: Can't get Wireless Networking working with TP-link TL-WN722N wireless card

    Here is exactly what I did, step by step.
    First, lsmod.

    Code:
    root@bt:~# lsmod | grep -i ath9k
    ath9k                 154391  0 
    ath9k_htc              95301  0 
    mac80211              612653  2 ath9k,ath9k_htc
    ath9k_common           13606  2 ath9k,ath9k_htc
    ath9k_hw              428784  3 ath9k,ath9k_htc,ath9k_common
    ath                    23032  4 ath9k,ath9k_htc,ath9k_common,ath9k_hw
    cfg80211              526534  4 ath9k,ath9k_htc,mac80211,ath
    compat                 24704  6 ath9k,ath9k_htc,mac80211,ath9k_common,ath9k_hw,cfg80211
    Then, unplugged adapter and ran these:

    Code:
    root@bt:~# modprobe -rf ath9k
    root@bt:~# modprobe -rf ath9k_htc
    root@bt:~# rfkill unblock all 
    root@bt:~# modprobe ath9k_htc
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    Then, plugged adapter back in and tried to start wicd and networking.
    Still nothing. Then unplugged adapter and ran these:

    Code:
    root@bt:~# cat /boot/config-3.2.6 | grep -i config_ath
    CONFIG_ATH_COMMON=m
    # CONFIG_ATH_DEBUG is not set
    CONFIG_ATH5K=m
    # CONFIG_ATH5K_DEBUG is not set
    # CONFIG_ATH5K_TRACER is not set
    CONFIG_ATH5K_PCI=y
    CONFIG_ATH9K_HW=m
    CONFIG_ATH9K_COMMON=m
    CONFIG_ATH9K=m
    CONFIG_ATH9K_PCI=y
    CONFIG_ATH9K_AHB=y
    CONFIG_ATH9K_DEBUGFS=y
    CONFIG_ATH9K_RATE_CONTROL=y
    CONFIG_ATH9K_HTC=m
    CONFIG_ATH9K_HTC_DEBUGFS=y
    CONFIG_ATH6KL=m
    # CONFIG_ATH6KL_DEBUG is not set
    root@bt:~# reboot
    Then, plugged adapter back in.

    Code:
    root@bt:~# startx
    Disconnected adapter, then:

    Code:
    root@bt:~# modprobe -rf ath9k
    root@bt:~# modprobe -rf ath9k_htc
    root@bt:~# rfkill unblock all
    root@bt:~# modprobe ath9k_htc
    root@bt:~# service networking start 
    networking stop/waiting
    root@bt:~# service wicd start
     * Starting Network connection manager wicd                              [ OK ] 
    root@bt:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    root@bt:~#
    I am baffled. I really have no idea what could be causing this.
    Thanks a ton for trying to help me out!

Page 1 of 2 12 LastLast

Similar Threads

  1. D-Link DWA 556 Xtreme Wireless N Wifi Card
    By quacker99 in forum Non Working Hardware
    Replies: 0
    Last Post: 01-10-2012, 08:23 AM
  2. Wireless D-link DWA-130 Usb Adapter not Working
    By Roter1337 in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 07-16-2011, 02:47 AM
  3. Link 5100 wireless card injection problem
    By dorown in forum OLD Bt4beta Non-Working Hardware
    Replies: 5
    Last Post: 06-25-2009, 08:28 PM
  4. How to link Between Bt4 on vmWare and Wireless Card on XP
    By new_man in forum OLD Newbie Area
    Replies: 1
    Last Post: 06-11-2009, 11:21 AM
  5. Link for working wireless cards
    By pimpplaya in forum OLD Newbie Area
    Replies: 1
    Last Post: 04-09-2008, 05:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •