Results 1 to 2 of 2

Thread: Ruby Gems won't install!

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    1

    Default Ruby Gems won't install!

    hi, I am having a lot of difficulties getting rubygems1.9.1 to install. Every time I try, get this message:

    Code:
    root@bt:~# sudo apt-get install rubygems1.9.1 Reading package lists... Done Building dependency tree Reading state information... Done Suggested packages: rubygems-doc The following NEW packages will be installed: rubygems1.9.1 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 0B/201kB of archives. After this operation, 864kB of additional disk space will be used. Selecting previously deselected package rubygems1.9.1. (Reading database ... 397621 files and directories currently installed.) Unpacking rubygems1.9.1 (from .../rubygems1.9.1_1.3.7-1~uorppa0_all.deb) ... Processing triggers for man-db ... Setting up rubygems1.9.1 (1.3.7-1~uorppa0) ... update-alternatives: error: alternative gem can't be master: it is a slave of ruby dpkg: error processing rubygems1.9.1 (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: rubygems1.9.1 E: Sub-process /usr/bin/dpkg returned an error code (1)
    I have tried multiple steps from searching google to try to remove it completely to reinstall, but none seem to have worked yet.

    The commands include
    Code:
    sudo apt-get clean
    sudo apt-get autoremove
    sudo apt-get -f install 
    sudo apt-get remove rubygems1.9.1
    sudo dpkg --configure -a
    sudo dpkg -r rubygems1.9.1
    sudo dpkg -P rubygems1.9.1
    sudo apt-get install -reinstall rubygems1.9.1
    sudo dpkg --remove --force-remove-reinstreq rubygems1.9.1
    sudo apt-get remove --purge rubygems1.9.1
    sudo apt-get -s remove --purge rubygems1.9.1
    locate rubygems1.9.1 (then rm -rf all of the locations listed)
    sudo gedit /var/lib/dpkg/status (searching for rubygems1.9.1 and removing that entire block)
    So far, I have had no luck and each relevant step was followed by a sudo apt-get update && sudo apt-get install rubygems1.9.1

    Any help with this would be outstanding.

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Ruby Gems won't install!

    Well, how about checking the /var/lib/dpkg/info and look for every file matching "your package" (rubygems), and delete them all. Then make an autoclean to the /var/cache/apt/archives: aptitude autoclean (to remove the packages that cannot be downloaded).
    Then clean all other .deb packages with clean: aptitude clean.

    Now, try this: aptitude purge "your package". If an error comes up, then it never got to install completely, it did not even got to create any configuration files, then just remove it: aptitude remove "your package"..

    Then, try to install: aptitude install "your package"

    See what happens.
    Last edited by maverik35; 02-11-2013 at 04:09 PM.

Similar Threads

  1. [ERROR] Install missing ruby gem when running wpscan
    By abraoximenes in forum BackTrack 5 Bugs
    Replies: 1
    Last Post: 10-03-2012, 02:32 PM
  2. Ruby Gems Error after Metasploit Update
    By blakhal0 in forum BackTrack Bugs
    Replies: 7
    Last Post: 01-19-2011, 03:21 AM
  3. Updating Ruby gems
    By hightech in forum Beginners Forum
    Replies: 1
    Last Post: 12-06-2010, 10:26 PM
  4. Goorecon cannot access ruby gems???
    By NewJack in forum Beginners Forum
    Replies: 4
    Last Post: 06-20-2010, 08:47 PM
  5. Learning ruby... My first ruby backdoor...
    By BigMac in forum OLD Programming
    Replies: 9
    Last Post: 06-03-2009, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •