Results 1 to 3 of 3

Thread: Fastlib error after launching msfconsole

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    1

    Default Fastlib error after launching msfconsole

    Getting a weird error on the latest update when attempting to launch msfconsole. Just wanted to see if anyone else was getting it or if its an isolated occurrence.

    Running on GNOME
    Running in VMware Fusion

    root@bt:~# msfconsole
    /opt/metasploit/msf3/lib/fastlib.rb:374:in `require': /opt/metasploit/msf3/lib/msf/util/exe.rb:2: syntax error, unexpected tLSHFT (SyntaxError)
    <<<<<<< .mine
    ^
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/util.rb:23:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/core/framework.rb:3:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/core.rb:34:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui/console/driver.rb:2:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui/console.rb:11:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui.rb:11:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/msfconsole:136:in `<main>'
    root@bt:~#

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Fastlib error after launching msfconsole

    This doesn't seem like a Backtrack bug, I recommend you reinstall metasploit
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    1

    Default Re: Fastlib error after launching msfconsole

    Try the following command it worked for me
    apt-get update && apt-get upgrade

    Quote Originally Posted by Ronin609 View Post
    Getting a weird error on the latest update when attempting to launch msfconsole. Just wanted to see if anyone else was getting it or if its an isolated occurrence.

    Running on GNOME
    Running in VMware Fusion

    root@bt:~# msfconsole
    /opt/metasploit/msf3/lib/fastlib.rb:374:in `require': /opt/metasploit/msf3/lib/msf/util/exe.rb:2: syntax error, unexpected tLSHFT (SyntaxError)
    <<<<<<< .mine
    ^
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/util.rb:23:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/core/framework.rb:3:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/core.rb:34:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui/console/driver.rb:2:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui/console.rb:11:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/msf/ui.rb:11:in `<top (required)>'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/lib/fastlib.rb:374:in `require'
    from /opt/metasploit/msf3/msfconsole:136:in `<main>'
    root@bt:~#

Similar Threads

  1. Problem while launching BT5
    By evilkid in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 01-26-2012, 12:22 AM
  2. Launching testdisk?
    By hrturner in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 06-15-2011, 02:07 PM
  3. Error launching VirtualBox in backtrack R2
    By gandip in forum Beginners Forum
    Replies: 0
    Last Post: 03-22-2011, 05:53 PM
  4. Metasploit msfconsole search command error
    By ro9-bt in forum OLD Newbie Area
    Replies: 1
    Last Post: 10-03-2009, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •