Results 1 to 8 of 8

Thread: Error while updating BackTrack 5 R3

  1. #1
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    3

    Question Error while updating BackTrack 5 R3

    I am using BackTrack 5 R3 Virtual Machine in VirtualBox.
    Recently, when I was updating BackTrack (by using the command "apt-get update && apt-get upgrade && apt-get dist-upgrade"), I had to forcibly power off the VM. The updates were being installed at that time.
    Now, when I try to update, I am getting the following error.

    Code:
    root@bt:~# apt-get update && apt-get upgrade && apt-get dist-upgrade
    Hit http://all.repository.backtrack-linux.org revolution Release.gpg           
    Hit http://32.repository.backtrack-linux.org revolution Release.gpg            
    Hit http://updates.repository.backtrack-linux.org revolution Release.gpg
    Ign http://all.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Ign http://32.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://all.repository.backtrack-linux.org revolution Release
    Hit http://32.repository.backtrack-linux.org revolution Release
    Hit http://updates.repository.backtrack-linux.org revolution Release 
    Hit http://all.repository.backtrack-linux.org revolution/main Packages
    Hit http://32.repository.backtrack-linux.org revolution/main Packages
    Hit http://updates.repository.backtrack-linux.org revolution/main Packages
    Hit http://all.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://32.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://updates.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://all.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://32.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://updates.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://all.repository.backtrack-linux.org revolution/testing Packages
    Hit http://32.repository.backtrack-linux.org revolution/testing Packages
    Hit http://updates.repository.backtrack-linux.org revolution/testing Packages
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up w3af (1.2-bt2) ...
    tar: pybloomfiltermmap-0.2.0.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
    python: can't open file 'setup.py': [Errno 2] No such file or directory
    svn: Working copy 'w3af' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)
    dpkg: error processing w3af (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     w3af
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Somebody please help..
    I dont want to loose the latest updates..
    Thank You..

  2. #2
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    3

    Default Re: Error while updating BackTrack 5 R3

    Maybe you can try

    Code:
    apt-get clean
    Gruß.

  3. #3
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    3

    Default Re: Error while updating BackTrack 5 R3

    Quote Originally Posted by davidbmnn View Post
    Maybe you can try

    Code:
    apt-get clean
    Gruß.
    Its not working....
    I tried to update again and gave the above code, but no use..

  4. #4
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    3

    Default Re: Error while updating BackTrack 5 R3

    Quote Originally Posted by davidbmnn View Post
    Maybe you can try

    Code:
    apt-get clean
    Gruß.
    How to use this code...
    I tried to update again, and after the error msg i tried the above command in the same terminal window. the command was executed but it didnt show any msgs. i tried to update again after that. but the result was the same. no change..

  5. #5
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Error while updating BackTrack 5 R3

    Try :

    aptitude remove w3af do not use purge yet, it seems you have a broken pakage..

    then
    1. aptitude clean (cleans all .deb "package stock" in /var/cache/apt/archives)
    2. aptitude update
    3. aptitude full-upgrade

    Luck.

  6. #6
    Just burned their ISO Parad0x001's Avatar
    Join Date
    Oct 2012
    Posts
    6

    Default Re: Error while updating BackTrack 5 R3

    Quote Originally Posted by maverik35 View Post
    Try :

    aptitude remove w3af do not use purge yet, it seems you have a broken pakage..

    then
    1. aptitude clean (cleans all .deb "package stock" in /var/cache/apt/archives)
    2. aptitude update
    3. aptitude full-upgrade

    Luck.
    Still the same:

    root@bt:~# aptitude clean
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Writing extended state information... Done
    root@bt:~# aptitude update
    Hit http://archive.ubuntu.com lucid Release.gpg
    Ign http://archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
    Ign http://archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
    Ign http://archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
    Ign http://archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
    Hit http://archive.ubuntu.com lucid Release
    Hit http://archive.ubuntu.com lucid/multiverse Packages
    Hit http://all.repository.backtrack-linux.org revolution Release.gpg
    Hit http://64.repository.backtrack-linux.org revolution Release.gpg
    Ign http://64.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://64.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Hit http://updates.repository.backtrack-linux.org revolution Release.gpg
    Ign http://updates.repository.backtrack-linux.org/ revolution/main Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/microverse Translation-en_US
    Hit http://archive.ubuntu.com lucid/main Packages
    Hit http://archive.ubuntu.com lucid/restricted Packages
    Hit http://archive.ubuntu.com lucid/universe Packages
    Ign http://all.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://all.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://all.repository.backtrack-linux.org revolution Release
    Ign http://64.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/non-free Translation-en_US
    Ign http://updates.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://updates.repository.backtrack-linux.org revolution Release
    Ign http://64.repository.backtrack-linux.org/ revolution/testing Translation-en_US
    Hit http://64.repository.backtrack-linux.org revolution Release
    Hit http://all.repository.backtrack-linux.org revolution/main Packages
    Hit http://64.repository.backtrack-linux.org revolution/main Packages
    Hit http://updates.repository.backtrack-linux.org revolution/main Packages
    Hit http://all.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://updates.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://updates.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://updates.repository.backtrack-linux.org revolution/testing Packages
    Hit http://all.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://all.repository.backtrack-linux.org revolution/testing Packages
    Hit http://64.repository.backtrack-linux.org revolution/microverse Packages
    Hit http://64.repository.backtrack-linux.org revolution/non-free Packages
    Hit http://64.repository.backtrack-linux.org revolution/testing Packages
    Reading package lists... Done

    root@bt:~# aptitude full-upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following packages will be REMOVED:
    bogl-bterm{u} cryptsetup{u} dmraid{u} ecryptfs-utils{u} libdebconfclient0{u}
    libdebian-installer4{u} libdmraid1.0.0.rc16{u} libecryptfs0{u} linux-source-3.2.6{u}
    python-pyicu{u} rdate{u} reiserfsprogs{u}
    The following partially installed packages will be configured:
    subterfuge
    0 packages upgraded, 0 newly installed, 12 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 84.0MB will be freed.
    Do you want to continue? [Y/n/?] y
    (Reading database ... 255834 files and directories currently installed.)
    Removing bogl-bterm ...
    Removing cryptsetup ...
    update-initramfs: deferring update (trigger activated)
    Removing dmraid ...
    update-initramfs: deferring update (trigger activated)
    Removing ecryptfs-utils ...
    Removing libdebconfclient0 ...
    Removing libdebian-installer4 ...
    Removing libdmraid1.0.0.rc16 ...
    Removing libecryptfs0 ...
    Removing linux-source-3.2.6 ...
    Removing python-pyicu ...
    Removing rdate ...
    Removing reiserfsprogs ...
    Processing triggers for man-db ...
    Processing triggers for ureadahead ...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-2.6.32-21-generic
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Processing triggers for python-support ...
    Setting up subterfuge (4.3-bt0) ...
    tar: SubterfugePublicBeta4.3.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/subterfuge.postinst: line 6: cd: subterfuge/: No such file or directory
    python: can't open file 'installer_old.py': [Errno 2] No such file or directory
    rm: cannot remove `SubterfugePublicBeta4.3.tar.gz': No such file or directory
    dpkg: error processing subterfuge (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    subterfuge
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    Setting up subterfuge (4.3-bt0) ...
    tar: SubterfugePublicBeta4.3.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/subterfuge.postinst: line 6: cd: subterfuge/: No such file or directory
    python: can't open file 'installer_old.py': [Errno 2] No such file or directory
    rm: cannot remove `SubterfugePublicBeta4.3.tar.gz': No such file or directory
    dpkg: error processing subterfuge (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    subterfuge
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Writing extended state information... Done

    root@bt:~#

  7. #7
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: Error while updating BackTrack 5 R3

    Quote Originally Posted by Parad0x001 View Post
    Still the same:
    Hi
    I think you have '' OPEN'' a ubuntu repository in addition to those backtrack

  8. #8
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Error while updating BackTrack 5 R3

    You are certainly correct, zimmaro.

    I didn't read the post closley..My mistake.

    You need to edit the /etc/apt/sources.list and just leave the BT5r3 repos. Unless you had install something from the ubuntu repos, just comment the ubuntu repos lines. Try again.

    Luck.

Similar Threads

  1. Error updating BT5
    By actinio in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 09-08-2011, 03:18 AM
  2. Error Updating Msf
    By billyONair in forum Beginners Forum
    Replies: 0
    Last Post: 03-21-2011, 11:50 PM
  3. Error updating kernel 2.6.34
    By StasNep in forum Beginners Forum
    Replies: 10
    Last Post: 10-18-2010, 03:09 AM
  4. updating MSF3 from repository SVN error fix
    By dustyboner in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 0
    Last Post: 11-23-2009, 12:46 PM
  5. bug - updating kdelibs creates error!!!
    By thont in forum OLD BT3beta Software related issues
    Replies: 2
    Last Post: 05-27-2008, 09:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •