Results 1 to 6 of 6

Thread: Nikto error Undefined subroutine &main::get_ips

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Feb 2010
    Posts
    22

    Default Nikto error Undefined subroutine &main::get_ips

    Hi
    Any one know who can I fix this error?

    root@bt:/pentest/web/nikto# perl nikto.pl -update
    + No updates required.
    + CIRT.net message: Please submit Nikto bugs to http://trac2.assembla.com/Nikto_2/report/2
    root@bt:/pentest/web/nikto# perl nikto.pl -host 192.168.186.12
    - Nikto v2.1.5
    ---------------------------------------------------------------------------
    + Target IP: 130.243.57.232
    + Target Hostname: fronter.du.se
    + Target Port: 80
    + Start Time: 2013-02-04 15:15:43 (GMT1)
    ---------------------------------------------------------------------------
    + Server: Apache/2.2.3 (Ubuntu) PHP/5.2.1 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_apreq2-20051231/2.6.0 mod_perl/2.0.2 Perl/v5.8.8
    Undefined subroutine &main::get_ips called at /pentest/web/nikto/plugins/nikto_headers.plugin line 72.
    root@bt:/pentest/web/nikto#

  2. #2
    Senior Member
    Join Date
    Jul 2010
    Location
    UK
    Posts
    136

    Default Re: Nikto error Undefined subroutine &main::get_ips

    try
    Code:
    svn up
    What version of BT are you running?

  3. #3
    Just burned their ISO
    Join Date
    Feb 2010
    Posts
    22

    Default Re: Nikto error Undefined subroutine &main::get_ips

    Thanks Sir
    svn up not work!!!
    Im running Backtrack 5 r3 32bit Gnome

    root@bt:/pentest/web/nikto# svn update


    svn: Failed to add file 'plugins/nikto_clientaccesspolicy.plugin': an unversioned file of the same name already exists



    Now I got this error????

    root@bt:~# cd /pentest/web/nikto/
    root@bt:/pentest/web/nikto# ls
    docs nikto.conf nikto.pl plugins templates
    root@bt:/pentest/web/nikto# ./nikto.pl
    Can't locate /pentest/web/nikto/plugins/nikto_single.plugin in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ./nikto.pl line 87.
    Last edited by matrix75; 02-04-2013 at 04:16 PM.

  4. #4
    Senior Member
    Join Date
    Jul 2010
    Location
    UK
    Posts
    136

    Default Re: Nikto error Undefined subroutine &main::get_ips

    Move all the files from the plugins directory and then try 'svn up' again.

  5. #5
    Just burned their ISO
    Join Date
    Feb 2010
    Posts
    22

    Default Re: Nikto error Undefined subroutine &main::get_ips

    Thank you very much Sir,Its work now

    Thanks again...

  6. #6
    Senior Member
    Join Date
    Jul 2010
    Location
    UK
    Posts
    136

    Default Re: Nikto error Undefined subroutine &main::get_ips

    Glad it worked, thanks for posting back.

Similar Threads

  1. Replies: 5
    Last Post: 01-15-2011, 12:32 AM
  2. Nikto update error
    By vdubhack in forum BackTrack Bugs
    Replies: 0
    Last Post: 01-28-2010, 02:05 AM
  3. Undefined Video Mode Number
    By tom 123 in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-29-2009, 12:36 PM
  4. eeepc 701 - undefined video mode
    By imported_mhackling in forum OLD BT4beta Bugs and Fixes
    Replies: 3
    Last Post: 03-18-2009, 12:20 AM
  5. error msg when trying to mount main partition under Konqueror
    By MosGuy in forum OLD BT3final Support
    Replies: 8
    Last Post: 09-08-2008, 07:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •