Results 1 to 5 of 5

Thread: Beef error

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Beef error

    Dear forum users,

    When I run this command:
    root@bt:~# apt-get install beef
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    beef is already the newest version.
    The following packages were automatically installed and are no longer required:
    libdmraid1.0.0.rc16 python-pyicu libdebian-installer4 cryptsetup libecryptfs0 reiserfsprogs rdate
    bogl-bterm ecryptfs-utils libdebconfclient0 dmraid
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up beef (0.4.3.5-bt1) ...
    WARNING: You don't have /root/.gem/ruby/1.9.2/bin in your PATH,
    gem executables will not run.
    Successfully installed bundler-1.2.3
    1 gem installed
    Installing ri documentation for bundler-1.2.3...
    Installing RDoc documentation for bundler-1.2.3...
    Fetching gem metadata from http://rubygems.org/.........
    Fetching gem metadata from http://rubygems.org/..
    Using addressable (2.2.8)
    Using ansi (1.4.3)
    Using daemons (1.1.9)
    Using data_objects (0.10.11)
    Using dm-core (1.2.0)
    Using dm-do-adapter (1.2.0)
    Using dm-migrations (1.2.0)
    Using do_sqlite3 (0.10.11)
    Using dm-sqlite-adapter (1.2.0)
    Using eventmachine (0.12.10)
    Using em-websocket (0.3.8)
    Using erubis (2.7.0)
    Using jsmin (1.0.1)
    Using json (1.7.6)

    I get this error:
    Gem::Package::FormatError: No metadata found!
    An error occurred while installing librex (0.0.68), and Bundler cannot continue.
    Make sure that `gem install librex -v '0.0.68'` succeeds before bundling.

    dpkg: error processing beef (--configure):
    subprocess installed post-installation script returned error exit status 5
    Setting up subterfuge (4.3-bt0) ...
    tar: SubterfugePublicBeta4.3.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/subterfuge.postinst: line 6: cd: subterfuge/: No such file or directory
    python: can't open file 'installer_old.py': [Errno 2] No such file or directory
    rm: cannot remove `SubterfugePublicBeta4.3.tar.gz': No such file or directory
    dpkg: error processing subterfuge (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    beef
    subterfuge
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@bt:~#

    Because when update metasploit framework its get a error saying Beef problems.
    How can i solve this issue.

    With kind regards from,
    ScorpionKing28

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Beef error

    Read the error output carefully:

    Code:
    Make sure that `gem install librex -v '0.0.68'` succeeds before bundling.


    Get that installed first than try it again.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Re: Beef error

    Quote Originally Posted by sickness View Post
    Read the error output carefully:

    Code:
    Make sure that `gem install librex -v '0.0.68'` succeeds before bundling.


    Get that installed first than try it again.
    But how can i install this, i search all over the net and I cannot find it.
    And thanks for the reply.

    With kind regards from,
    ScorpionKing28

  4. #4
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: Beef error

    Again as I said read your error message

    Other than that Backtrack is not a beginners distribution, you will have to learn Linux and do a lot of research on your own to use it.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  5. #5
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    1

    Lightbulb Re: Beef error

    I have fix it

    just try

    Code:
    sudo gedit /var/lib/dpkg/info/beef.postinst
    and add
    Code:
    #!/bin/bash
    
    set -e
    exit 0
    same with

    Code:
    sudo gedit /var/lib/dpkg/info/subterfuge.postinst


    may help u

    :Newbie:

Similar Threads

  1. Problems upgrading BeEF (beef-ng) in Backtrack 5 R1
    By Perropoly in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 02-25-2012, 06:31 PM
  2. Replies: 0
    Last Post: 07-10-2011, 07:31 AM
  3. BEEF bug
    By morning_wood in forum BackTrack Bugs
    Replies: 1
    Last Post: 07-16-2010, 05:31 PM
  4. Where's the BeEF?
    By imported_bulgin in forum OLD Newbie Area
    Replies: 4
    Last Post: 12-13-2008, 10:34 AM
  5. beef in bt3 !
    By shamanvirtuel in forum OLD Pentesting
    Replies: 0
    Last Post: 12-04-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •