Page 6 of 6 FirstFirst ... 456
Results 51 to 54 of 54

Thread: Intel integrated graphics are not working

  1. #51
    Just burned their ISO
    Join Date
    May 2011
    Posts
    3

    Default Re: Intel integrated graphics are not working

    did you installed the xserver-xorg-video-intel drivers? - don't know how, i have
    just upgrade kernel!

    what does your /etc/default/grub look like?
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1024x768
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    apt-cache policy xserver-xorg-video-intel
    Code:
    xserver-xorg-video-intel:
      Installed: 2:2.9.1-3ubuntu5
      Candidate: 2:2.9.1-3ubuntu5
      Version table:
     *** 2:2.9.1-3ubuntu5 0
            500 http://32.repository.backtrack-linux.org/ revolution/main Packages
            100 /var/lib/dpkg/status

  2. #52
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    10

    Default Re: Intel integrated graphics are not working

    alright, intel drivers are installed but they are very old.

    follow these steps:

    1) apt-get install python-software-properties
    2) add-apt-repository ppa:glasen/intel-driver
    3) apt-get update
    4) apt-get install xserver-xorg-video-intel

    5) change following to your /etc/default/grub line:
    GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1 i915.i915_enable_rc6=1 i915.semaphores=1 pcie_aspm=force"

    6) when finished editing /etc/default/grub --> update-grub
    7) reboot

    after reboot check if you got the newer drivers from glasen installed via
    Code:
     apt-cache policy xserver-xorg-video-intel
    version number should be higher and the repo should changed to glasen......whatever

    that should do the trick.

  3. #53
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by templar13 View Post
    did you installed the xserver-xorg-video-intel drivers? - don't know how, i have
    just upgrade kernel!

    what does your /etc/default/grub look like?
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1024x768
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    apt-cache policy xserver-xorg-video-intel
    Code:
    xserver-xorg-video-intel:
      Installed: 2:2.9.1-3ubuntu5
      Candidate: 2:2.9.1-3ubuntu5
      Version table:
     *** 2:2.9.1-3ubuntu5 0
            500 http://32.repository.backtrack-linux.org/ revolution/main Packages
            100 /var/lib/dpkg/status
    There seems to be a bug in the BT5 r3 kernel, i915 module and Ivy Bridge Technology (Intel 3rd Gen). The fix is as stated by tr00ner: install the Kernel version: 3.2.15, not another one, it has to be that version. Then just set (enable framebuffer) module i915.modeset=1 or nomodset in case modeset=1 does not do the work..Once it works, make it permanent.

    If you do not do that, Video driver will fallback to fb....

    The rest is for power savings..You can omit them if you want.

    By the way, the other fix is again as stated by Tr00ner: install Kali linux...As I stated in my post, it has a Kernel version 3.7 (very high) so it will load i915 without hassels..It should work out of the box.

    Thanx Tr00ner for another UPDATE..
    Last edited by maverik35; 03-18-2013 at 03:46 PM.

  4. #54
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    10

    Default Re: Intel integrated graphics are not working

    @maverik35
    you are welcome

Page 6 of 6 FirstFirst ... 456

Similar Threads

  1. Intel Integrated Graphics - Resolution Issue
    By Calamita in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 05-26-2012, 06:13 PM
  2. Replies: 2
    Last Post: 04-21-2012, 09:21 AM
  3. Replies: 0
    Last Post: 01-09-2012, 02:12 AM
  4. Replies: 28
    Last Post: 03-30-2011, 08:37 PM
  5. Screen resolution problem, Intel integrated graphics
    By Big Boss in forum Beginners Forum
    Replies: 3
    Last Post: 10-13-2010, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •