Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 54

Thread: Intel integrated graphics are not working

  1. #21
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    maverik35,

    one more thing after running modprobe -v i915 modeset=1 , it displays the kernel driver module loaded i915 but the problem remains same of 3'' screen shift to right. Also logs generated after issuing that command i had already replied.

  2. #22
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Intel integrated graphics are not working

    Yes i915 supports the HD4000..

    There is a conflict between the frame buffer with efi vga...You might want to disable the gfxmode parameter when booting..

    Boot again, once in terminal mode, edit with nano the /etc/default/grub and comment the line : GRUB_GFXMODE=1025x768 or whatever the resolution is:
    # GRUB_GFXMODE=1025x768

    See if it boots...

  3. #23
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by maverik35 View Post
    Yes i915 supports the HD4000..

    There is a conflict between the frame buffer with efi vga...You might want to disable the gfxmode parameter when booting..

    Boot again, once in terminal mode, edit with nano the /etc/default/grub and comment the line : GRUB_GFXMODE=1025x768 or whatever the resolution is:
    # GRUB_GFXMODE=1025x768

    See if it boots...
    i Tried what u suggested by commenting gfxmode line , if i do that it goes to 640*480 mode by default and on executing modprobe still same error Which i posted earlier, with shift of screen.

    here is my grub file :

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1366x768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"


    this is my xorg file :


    Section "ServerLayout"
    Identifier "X.org Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath "built-ins"
    EndSection

    Section "Module"
    Load "dbe"
    Load "record"
    Load "extmod"
    Load "dri2"
    Load "dri"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    EndSection

    Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ### [arg]: arg optional
    #Option "ShadowFB" # [<bool>]
    #Option "Rotate" # <str>
    #Option "fbdev" # <str>
    #Option "debug" # [<bool>]
    Identifier "Card0"
    Driver "fbdev"
    VendorName "Intel Corporation"
    BoardName "3rd Gen Core processor Graphics Controller"
    BusID "PCI:0:2:0"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    SubSection "Display"
    Viewport 0 0
    Depth 1
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 4
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 8
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 15
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 16
    EndSubSection
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

  4. #24
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Intel integrated graphics are not working

    kernel is trying to load i965, I checked on intel hd4000 and it needs the i965 open driver.

    Sorry, my mistake, intel hd4000 is supported by i965 and NOT i915 driver...I'm very sorry...

    That is why the GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1" is using i965..

    Now please try to reload teh driver : modprobe i965 modeset=1

    Try it please. Now we move on to the i965 driver..
    Last edited by maverik35; 02-14-2013 at 03:40 PM.

  5. #25
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by maverik35 View Post
    kernel is trying to load i965, I checked on intel hd4000 and it needs the i965 open driver.

    Sorry, my mistake, intel hd4000 is supported by i965 and NOT i915 driver...I'm very sorry...

    That is why the GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1" is using i965..

    Now please try to reload teh driver : modprobe i965 modeset=1

    Try it please. Now we move on to the i965 driver..
    Its okay maverik 35, i appreciate for your effort that you are putting with me to fix this issue.
    Yes i tried doing modprobe for i965 but this is the error i am receiving :

    sudo modprobe i965 modeset=1
    FATAL: Module i965 not found.


    so, how could i install this module for i965 ?

  6. #26
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Intel integrated graphics are not working

    Thanks, but I feel the commitment to help anyone who needs it, and I do it gladly.

    One question, in the grub.cfg you copied/pasted? Because I see something strange, and let me quote:

    i Tried what u suggested by commenting gfxmode line , if i do that it goes to 640*480 mode by default and on executing modprobe still same error Which i posted earlier, with shift of screen.

    here is my grub file :

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1366x768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    I bolded and underlined the strange driver: i965..That made me think kernel 3.2 has it, but when you tried to loaded it, it comes up with: FATAL: Module i965 not found.???

    Please, go to /etc/default/grub and change the driver for the i915 and leave the modeset=1..Then update-grub and reboot.

    See what happens...Please, post the dmesg | grep -i intel

    If still the same thing, move to /etc/X11 and backupp your xorg.conf, then execute: Xorg -configure. It will create a new xorg.conf in the folder you are located at. In this case in /etc/X11, if not there, it must be in the root directory, just mv to /etc/X11. Reboot.
    Last edited by maverik35; 02-16-2013 at 06:46 PM.

  7. #27
    Just burned their ISO
    Join Date
    Dec 2012
    Location
    where I'm needed
    Posts
    20

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by maverik35 View Post
    kernel is trying to load i965, I checked on intel hd4000 and it needs the i965 open driver.

    Sorry, my mistake, intel hd4000 is supported by i965 and NOT i915 driver...I'm very sorry...

    That is why the GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1" is using i965..

    Now please try to reload teh driver : modprobe i965 modeset=1

    Try it please. Now we move on to the i965 driver..

    As far as I could read, there is no i965 kernel driver, see here for example: http://lists.freedesktop.org/archive...er/008943.html

    So, first, zigmos will need to do the "modprobe i915 modeset=1" before he does startx.


    Second, I noticed misconfiguration in the xorg.conf file posted by zigmos. I'll quote here the relevant section, with the mistake marked with red:
    Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
    ### [arg]: arg optional
    #Option "ShadowFB" # [<bool>]
    #Option "Rotate" # <str>
    #Option "fbdev" # <str>
    #Option "debug" # [<bool>]
    Identifier "Card0"
    Driver "fbdev"
    VendorName "Intel Corporation"
    BoardName "3rd Gen Core processor Graphics Controller"
    BusID "PCI:0:2:0"
    EndSection
    Please replace Driver "fbdev" with Driver "intel". Again, do this before you issue startx, obviously.


    And third, make sure you have Xorg Intel drivers installed from the ppa ( add-apt-repository ppa:glasen/intel-driver; apt-get update; apt-get upgrade).

    Now, you can issue startx !


    NOTE: You can check your Xorg Intel drivers version like this, copy/paste from my laptop follows:
    Code:
    # apt-cache policy xserver-xorg-video-intel                                                                                                                                                                       
    xserver-xorg-video-intel:                                                                                                                                                                                                         
      Installed: 2:2.15.0~lucid~ppa9                                                                                                                                                                                                  
      Candidate: 2:2.15.0~lucid~ppa9                                                                                                                                                                                                  
      Version table:                                                                                                                                                                                                                  
     *** 2:2.15.0~lucid~ppa9 0                                                                                                                                                                                                        
            500 http://ppa.launchpad.net/glasen/intel-driver/ubuntu/ lucid/main Packages                                                                                                                                              
            100 /var/lib/dpkg/status                                                                                                                                                                                                  
         2:2.9.1-3ubuntu5 0                                                                                                                                                                                                           
            500 http://64.repository.backtrack-linux.org/ revolution/main Packages                                                                                                                                                    
            500 http://updates.repository.backtrack-linux.org/ revolution/main Packages
    So, make sure that installed version is "2:2.15.0~lucid~ppa9".

    Good luck! Please post your results...

  8. #28
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by maverik35 View Post
    Thanks, but I feel the commitment to help anyone who needs it, and I do it gladly.

    One question, in the grub.cfg you copied/pasted? Because I see something strange, and let me quote:

    i Tried what u suggested by commenting gfxmode line , if i do that it goes to 640*480 mode by default and on executing modprobe still same error Which i posted earlier, with shift of screen.

    here is my grub file :

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1366x768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    I bolded and underlined the strange driver: i965..That made me think kernel 3.2 has it, but when you tried to loaded it, it comes up with: FATAL: Module i965 not found.???

    Please, go to /etc/default/grub and change the driver for the i915 and leave the modeset=1..Then update-grub and reboot.

    See what happens...Please, post the dmesg | grep -i intel

    If still the same thing, move to /etc/X11 and backupp your xorg.conf, then execute: Xorg -configure. It will create a new xorg.conf in the folder you are located at. In this case in /etc/X11, if not there, it must be in the root directory, just mv to /etc/X11. Reboot.
    hey,
    i changed grub line to: GRUB_CMDLINE_LINUX_DEFAULT="quite splash i915"

    Also, i reconfigured and replaced my xorg.conf file to new one.
    Result:

    dmesg | grep -i intel
    [ 0.000000] Intel GenuineIntel
    [ 0.056532] CPU0: Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz stepping 09
    [ 0.163919] Performance Events: PEBS fmt1+, generic architected perfmon, Intel PMU driver.
    [ 0.978484] intel_idle: MWAIT substates: 0x21120
    [ 0.978485] intel_idle: does not run on family 6 model 58
    [ 1.446480] agpgart-intel 0000:00:00.0: Intel Ivybridge Chipset
    [ 1.447577] agpgart-intel 0000:00:00.0: detected gtt size: 2097152K total, 262144K mappable
    [ 1.449542] agpgart-intel 0000:00:00.0: detected 65536K stolen memory
    [ 1.450681] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0x80000000
    [ 8.354371] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
    [ 8.354416] snd_hda_intel 0000:00:1b.0: irq 43 for MSI/MSI-X
    [ 8.354441] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
    [ 9.836411] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
    [ 9.836823] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
    [ 9.836971] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8



    Still it seems to be same , as xorg file still shows "fbdev driver"
    And if i manually change it to "intel" then graphics crashes and startx doesn't start.

  9. #29
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by maverik35 View Post
    Thanks, but I feel the commitment to help anyone who needs it, and I do it gladly.

    One question, in the grub.cfg you copied/pasted? Because I see something strange, and let me quote:

    i Tried what u suggested by commenting gfxmode line , if i do that it goes to 640*480 mode by default and on executing modprobe still same error Which i posted earlier, with shift of screen.

    here is my grub file :

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=1366x768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    I bolded and underlined the strange driver: i965..That made me think kernel 3.2 has it, but when you tried to loaded it, it comes up with: FATAL: Module i965 not found.???

    Please, go to /etc/default/grub and change the driver for the i915 and leave the modeset=1..Then update-grub and reboot.

    See what happens...Please, post the dmesg | grep -i intel

    If still the same thing, move to /etc/X11 and backupp your xorg.conf, then execute: Xorg -configure. It will create a new xorg.conf in the folder you are located at. In this case in /etc/X11, if not there, it must be in the root directory, just mv to /etc/X11. Reboot.
    hey,
    i changed grub line to: GRUB_CMDLINE_LINUX_DEFAULT="quite splash i915"

    Also, i reconfigured and replaced my xorg.conf file to new one.
    Result:

    dmesg | grep -i intel
    [ 0.000000] Intel GenuineIntel
    [ 0.056532] CPU0: Intel(R) Core(TM) i3-3110M CPU @ 2.40GHz stepping 09
    [ 0.163919] Performance Events: PEBS fmt1+, generic architected perfmon, Intel PMU driver.
    [ 0.978484] intel_idle: MWAIT substates: 0x21120
    [ 0.978485] intel_idle: does not run on family 6 model 58
    [ 1.446480] agpgart-intel 0000:00:00.0: Intel Ivybridge Chipset
    [ 1.447577] agpgart-intel 0000:00:00.0: detected gtt size: 2097152K total, 262144K mappable
    [ 1.449542] agpgart-intel 0000:00:00.0: detected 65536K stolen memory
    [ 1.450681] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0x80000000
    [ 8.354371] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
    [ 8.354416] snd_hda_intel 0000:00:1b.0: irq 43 for MSI/MSI-X
    [ 8.354441] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
    [ 9.836411] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
    [ 9.836823] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
    [ 9.836971] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8



    Still it seems to be same , as xorg file still shows "fbdev driver"
    And if i manually change it to "intel" then graphics crashes and startx doesn't start.

  10. #30
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    19

    Default Re: Intel integrated graphics are not working

    Quote Originally Posted by WepWapWee View Post
    As far as I could read, there is no i965 kernel driver, see here for example: http://lists.freedesktop.org/archive...er/008943.html

    So, first, zigmos will need to do the "modprobe i915 modeset=1" before he does startx.


    Second, I noticed misconfiguration in the xorg.conf file posted by zigmos. I'll quote here the relevant section, with the mistake marked with red:

    Please replace Driver "fbdev" with Driver "intel". Again, do this before you issue startx, obviously.


    And third, make sure you have Xorg Intel drivers installed from the ppa ( add-apt-repository ppa:glasen/intel-driver; apt-get update; apt-get upgrade).

    Now, you can issue startx !


    NOTE: You can check your Xorg Intel drivers version like this, copy/paste from my laptop follows:
    Code:
    # apt-cache policy xserver-xorg-video-intel                                                                                                                                                                       
    xserver-xorg-video-intel:                                                                                                                                                                                                         
      Installed: 2:2.15.0~lucid~ppa9                                                                                                                                                                                                  
      Candidate: 2:2.15.0~lucid~ppa9                                                                                                                                                                                                  
      Version table:                                                                                                                                                                                                                  
     *** 2:2.15.0~lucid~ppa9 0                                                                                                                                                                                                        
            500 http://ppa.launchpad.net/glasen/intel-driver/ubuntu/ lucid/main Packages                                                                                                                                              
            100 /var/lib/dpkg/status                                                                                                                                                                                                  
         2:2.9.1-3ubuntu5 0                                                                                                                                                                                                           
            500 http://64.repository.backtrack-linux.org/ revolution/main Packages                                                                                                                                                    
            500 http://updates.repository.backtrack-linux.org/ revolution/main Packages
    So, make sure that installed version is "2:2.15.0~lucid~ppa9".

    Good luck! Please post your results...
    hey wepwapwee,

    i had tried manually changing driver from "fbdev " to "intel" after gui loads , i.e. i get logged into my gui, but after reboot it fails to load gui.
    Now, Pleas tell me one thing if i run modprobe command before startx , wont it be permanent if my graphics shifts ??How i will be able to revert it back then ?
    Also i had tried ppa glasen driver once, it did same and my graphics shifted by 3'' approx and that was permanent and i had to reinstall BT.
    So please suggest some backup plan so that if something goes wrong i could restore it back.

Page 3 of 6 FirstFirst 12345 ... LastLast

Similar Threads

  1. Intel Integrated Graphics - Resolution Issue
    By Calamita in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 05-26-2012, 06:13 PM
  2. Replies: 2
    Last Post: 04-21-2012, 09:21 AM
  3. Replies: 0
    Last Post: 01-09-2012, 02:12 AM
  4. Replies: 28
    Last Post: 03-30-2011, 08:37 PM
  5. Screen resolution problem, Intel integrated graphics
    By Big Boss in forum Beginners Forum
    Replies: 3
    Last Post: 10-13-2010, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •