did you installed the xserver-xorg-video-intel drivers? - don't know how, i have
just upgrade kernel!

what does your /etc/default/grub look like?
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
apt-cache policy xserver-xorg-video-intel
Code:
xserver-xorg-video-intel:
  Installed: 2:2.9.1-3ubuntu5
  Candidate: 2:2.9.1-3ubuntu5
  Version table:
 *** 2:2.9.1-3ubuntu5 0
        500 http://32.repository.backtrack-linux.org/ revolution/main Packages
        100 /var/lib/dpkg/status