Hi
I hope you could help me because I've been trying to solve this out, but I couldn't find how to solve it, if you help me i'll be very thankful!
Basically the problem is that i can't change the resolution, and in monitor preferences, doesn't detect the monitor it said that is unknown
This is the info with the comand lspci

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b4)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
-------------------------------------------------------------------------------------------------------------------------
this is the info of

glxinfo | grep -i render

direct rendering: Yes
OpenGL renderer string: Software Rasterizer
-------------------------------------------------------------------------------------------------------------------------
and the xorg.conf data is

# bare-bones XFree86 config to start the server in probe-only mode
Section "Files"
FontPath "/usr/share/X11/fonts/misc"
RgbPath "/etc/X11/rgb.txt"
EndSection
Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection
Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "extmod"
Load "freetype"
Load "int10"
Load "record"
Load "vbe"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection
Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection
Section "Device"
Identifier "Generic Device"
Driver ":RIVER::"
EndSection
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Generic Device"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768""600x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768""600x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768""600x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768""600x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768""600x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768""600x800"
EndSubSection
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Generic Mouse"
EndSection
-------------------------------------------------------------------------------------------------------------------------
I manually wrote "600x800" in the xorg.conf to test if i was able to change the resolution, but didn't work.