Results 1 to 6 of 6

Thread: How do I disable internal Wireless card in BT5?

  1. #1
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    15

    Question How do I disable internal Wireless card in BT5?

    Hello,

    I am learning about Backtrack (and also getting some lessons in Linux as well) and had a quick question. I've got a wireless adapter hooked up to my laptop but I haven't been able to find a way to disable the internal wireless card. I've got the laptop set up to dual boot with BT5 and Windows, so it would be perfect if I could disable the internal wireless card in BT5 and leave it up and running in Windows 7, but if that's not possible, just disabling it for both OS's would be OK too.

    Any assistance would be greatly appreciated. Thanks!!

  2. #2
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Re: How do I disable internal Wireless card in BT5?

    ifconfig <interface> down
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  3. #3
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    15

    Default Re: How do I disable internal Wireless card in BT5?

    I've tried running ifconfig wlan0 down but when I run iwconfig I still see wlan0 (my internal wifi card) and wlan1 (my external wifi adapter). It's not the end of the world if I need to use wlan1, but I'm just trying to follow this beginner's book as closely as I can.

  4. #4
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    15

    Default Re: How do I disable internal Wireless card in BT5?

    To be a bit more specific, the issue I'm running into is that when I run airmon-ng start wlan1 (the wireless adapter) I get the following message:


    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng, or airtun-ng stops working after a short period of time, you may want to kill (some of) them!

    PID Name
    1436 dhclient3
    1523 dhclient3
    Process with PID 1436 (dhclient3) is running on interface wlan0


    So I figured I had to turn off wlan0 (the internal wireless card) in order to get past this error message.

  5. #5
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Re: How do I disable internal Wireless card in BT5?

    You might be able to disable the internal via the BIOS if you truly don't want to see it at all also some laptops have a physical switch to enable/disable it.
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  6. #6
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: How do I disable internal Wireless card in BT5?

    Quote Originally Posted by GLaDOS View Post
    I've tried running ifconfig wlan0 down but when I run iwconfig I still see wlan0 (my internal wifi card) and wlan1 (my external wifi adapter). It's not the end of the world if I need to use wlan1, but I'm just trying to follow this beginner's book as closely as I can.
    You can use wlan1 without disabling wlan0, I do no see any reason why not, even using the same chipset, they have their own alias (wlan1, wlan0, eth1, etc) and you make reference to each one using it...I do not see the problem...

    Now, if using Network Manager, you can use the keyfile plugin in NetworkManager.conf and add the option: unmanaged-devices with the format: unmanaged-devices=mac:xx:xx:xx:xx:xx:xx You can see here what I'm talking about..If you have more than one interface to be ignored, just use ";" and add another "mac:xx:xx..bla bla.."..

    Have you ever alter the NetworkManager?....If not, read before doing it, you can get in some issues, I talk by experience...Read about Network Manager.

    If using wicd, see if there is a networkmanager configuration file...

    Luck.

Similar Threads

  1. WiFi through VirtualBox via USB-Modem and internal wireless card.
    By synok in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 03-05-2012, 09:48 AM
  2. How to blacklist/disable completely my internal wifi card
    By khaos in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 09-17-2011, 08:15 PM
  3. What internal netbook wireless card should I buy?
    By Slayer537 in forum OLD BackTrack 4 General Support
    Replies: 5
    Last Post: 07-05-2009, 10:08 PM
  4. Instructions to turn off internal wireless card in BK3
    By dangrus in forum OLD Newbie Area
    Replies: 2
    Last Post: 01-02-2009, 08:27 PM
  5. What happened to my internal wireless card?
    By skiamakhe in forum OLD Newbie Area
    Replies: 0
    Last Post: 08-06-2007, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •