Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Macbook Pro 15/17" Late 2009 edition

  1. #11
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Macbook Pro 15/17" Late 2009 edition

    I installed BT4 using rEFit as my bootloader. Trackpad acts a little weird, the speed is slow and I can't use multi touch (obviously), but I guess speed can be adjusted. I'm trying to figure out how to install Broadcom drivers using ndiswrapper, but for now I'm stuck on an error since I don't have the ndiswrapper module installed. I'll let you know if I get it working.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  2. #12
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    2

    Default Re: Macbook Pro 15/17" Late 2009 edition

    Hey nightly, are you making any progress yet. Depending on what you find I might test my macbook.

  3. #13
    Junior Member nightlybuild's Avatar
    Join Date
    Feb 2010
    Location
    InYourBucci/Chicago
    Posts
    36

    Default Re: Macbook Pro 15/17" Late 2009 edition

    Quote Originally Posted by Zero Day View Post
    Hey nightly, are you making any progress yet. Depending on what you find I might test my macbook.
    I've been looking up on Ubuntu pages since BT4 is Ubuntu based. Find your MacBook here: https://help.ubuntu.com/community/MacBook
    I'm trying different things on this page: https://help.ubuntu.com/community/MacBook4-1/Intrepid

    So far, I got my trackpad working...even multitouch and my eject button. I still couldn't get the broadcom wifi working. I took a little "Spring Break" from all the frustration...I'll get back to it soon.
    If you get tired of listening to your music... cat /vmlinuz > /dev/audio
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    Macbook 2.4Ghz Dual Core, 4GB Ram, Edimax EW-7318USG, BT4

  4. #14
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    1

    Default Re: Macbook Pro 15/17" Late 2009 edition

    Quote Originally Posted by nightlybuild View Post
    I've been looking up on Ubuntu pages since BT4 is Ubuntu based. Find your MacBook here: https://help.ubuntu.com/community/MacBook
    I'm trying different things on this page: https://help.ubuntu.com/community/MacBook4-1/Intrepid

    So far, I got my trackpad working...even multitouch and my eject button. I still couldn't get the broadcom wifi working. I took a little "Spring Break" from all the frustration...I'll get back to it soon.
    Has anyone tried using the 2.6.34 RC2 Kernel? It is supposed to have updates to the mac80211 stack and the broadcom wifi drivers..

  5. #15
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Default Re: Macbook Pro 15/17" Late 2009 edition

    I haven't tried these yet but they look like a more recent version of the sta drivers,

    Broadcom.com - 802.11 Linux STA driver

  6. #16
    Just burned his ISO
    Join Date
    Jul 2010
    Posts
    3

    Default Re: Macbook Pro 15/17" Late 2009 edition

    I'm not sure if I did it right, but I tried to install the drivers and it didn't bring up any lan device. lspci shows the card. I installed and then realized there was a patch for the latest kernel. I patched and re-installed but it still didn't work.

  7. #17
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    9

    Default Re: Macbook Pro 15/17" Late 2009 edition

    Greetings fellow back trackers,

    I can also verify a successful dual boot of my MacBook Pro 17' (4.1)
    Mac OS X 10.6
    BackTrack 4

    I understand that the airport extreme card may not have the abilities to do sniffing etc, (correct?)
    BUT yes, I would LOVE to have it working just for general internet connectioness.

    any news?

    Also, has anyone made a list of what all does work?
    Sound?
    backlit keyboard?
    etc....

  8. #18
    Just burned his ISO
    Join Date
    Aug 2010
    Posts
    4

    Default Re: Macbook Pro 15/17" Late 2009 edition

    How are you getting it to boot from USB? I have rEFIt (MBP 13" '09) but everytime I have a bootable USB it either says "Boot Legacy OS", or "Boot Windows from" and both just boot my bootcamp partition

Page 2 of 2 FirstFirst 12

Similar Threads

  1. "BackTrack 4 Final Released" not starting
    By habib in forum BackTrack Bugs
    Replies: 6
    Last Post: 02-07-2010, 11:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •