According to Wikipedia, even Backtrack 5 R3, the lastest version which was released on 8/2012 based on an old version of Ubuntu (10.04 Lucid) that won't be supported from April 2013. May be I'm a newbie, but I still wonder why a new version of Backtrack still based on an old Ubuntu version that was released more than two years ago.