Results 1 to 8 of 8

Thread: Is it impossible?

  1. #1
    linuxbeast
    Guest

    Default Is it impossible?

    I'd like to put a newer version of Skype in BT2 for VOIP. The version that is included with BT2 has bugs, and I get the message "Problem with sound device." When trying to make a call, others get the message "Problem with remote sound device." I have tried to upgrade Skype, but I get many errors.

    Code:
    bt skype-1.4.0.99 # LD_LIBRARY_PATH=/mnt/sda1/home/ivan/.32bitLibs:/mnt/sda1/usr/lib32/ LD_PRELOAD=/lib/tls/libc.so.6 ./skype
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libasound.so.2)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libQtDBus.so.4)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libQtGui.so.4)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libQtNetwork.so.4)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libQtCore.so.4)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libstdc++.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libX11.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libdbus-1.so.3)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/home/ivan/.32bitLibs/libQtXml.so.4)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libfontconfig.so.1)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libz.so.1)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libgthread-2.0.so.0)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libglib-2.0.so.0)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libaudio.so.2)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libXt.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libpng12.so.0)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libSM.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libICE.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libXcursor.so.1)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libfreetype.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libXext.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libXau.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libXdmcp.so.6)
    ./skype: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/sda1/usr/lib32/libexpat.so.1)
    bt skype-1.4.0.99 #
    Now I'm getting segmentation fault.

    Code:
    bt skype-1.4.0.99 # LD_LIBRARY_PATH=/mnt/sda1/home/chris/.32bitLibs:/mnt/sda1/usr/lib32/ LD_PRELOAD=/mnt/sda1/lib32/libc.so.6 ldd skype | grep -i no
    bt skype-1.4.0.99 # LD_LIBRARY_PATH=/mnt/sda1/home/chris/.32bitLibs:/mnt/sda1/usr/lib32/ LD_PRELOAD=/mnt/sda1/lib32/libc.so.6 strace ./skype
    Segmentation fault
    bt skype-1.4.0.99 #

  2. #2
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default

    You don't get "many" errors you get one error repeated many times.

    "version `GLIBC_2.4' not found "

    Try upgrading your GNU C Libraries.

  3. #3
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    well best thing is to use a precompiled binary :

    http://www.skype.com/go/getskype-linux-dynamic

    you just need to add this 2 libraries :
    libasound2 1.0.12
    libsigc++ 2.0.2
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  4. #4
    linuxbeast
    Guest

    Default

    Quote Originally Posted by shamanvirtuel View Post
    well best thing is to use a precompiled binary :

    http://www.skype.com/go/getskype-linux-dynamic

    you just need to add this 2 libraries :
    libasound2 1.0.12
    libsigc++ 2.0.2
    I'm trying that skype version you suggested.

    Code:
    bt skype-1.4.0.118 $ ldd skype | grep no
    ./skype: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by ./skype)
    ./skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by ./skype)
            libQtDBus.so.4 => not found
            libQtGui.so.4 => not found
            libQtNetwork.so.4 => not found
            libQtCore.so.4 => not found
            libsigc-2.0.so.0 => not found
    bt skype-1.4.0.118 $
    I see no slackware binaries for libsigc-2.0 available, so then I compiled libsigc++-2.0.18.

    Code:
    bt skype-1.4.0.118 # ldd skype | grep no
    ./skype: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by ./skype)
    ./skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by ./skype)
            libQtDBus.so.4 => not found
            libQtGui.so.4 => not found
            libQtNetwork.so.4 => not found
            libQtCore.so.4 => not found
            libsigc-2.0.so.0 => not found
    bt skype-1.4.0.118 # ldd
    ldd       lddlibc4
    bt skype-1.4.0.118 # ldconfig
    bt skype-1.4.0.118 # ldd skype | grep no
    ./skype: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by ./skype)
    ./skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by ./skype)
            libQtDBus.so.4 => not found
            libQtGui.so.4 => not found
            libQtNetwork.so.4 => not found
            libQtCore.so.4 => not found
    bt skype-1.4.0.118 #
    Why am I getting the first 2 errors about libstdc++?

  5. #5
    linuxbeast
    Guest

    Default

    I compiled this ftp://ftp.alsa-project.org/pub/lib/a....0.14a.tar.bz2. Why don't I have libaudio.so.2?

  6. #6
    linuxbeast
    Guest

    Default

    Quote Originally Posted by shamanvirtuel View Post
    well best thing is to use a precompiled binary :

    http://www.skype.com/go/getskype-linux-dynamic

    you just need to add this 2 libraries :
    libasound2 1.0.12
    libsigc++ 2.0.2
    Have you got it working? Are you able to get it working?

  7. #7
    Senior Member
    Join Date
    Jan 2006
    Posts
    1,334

    Default

    Quote Originally Posted by linuxbeast View Post
    I'd like to put a newer version of Skype in BT2 for VOIP. The version that is included with BT2 has bugs, and I get the message "Problem with sound device." When trying to make a call, others get the message "Problem with remote sound device." I have tried to upgrade Skype, but I get many errors....
    Please use sensible, descriptive post titles...

  8. #8
    linuxbeast
    Guest

    Default

    I found out how to get Skype not to give the "Problem with sound device.". Skype must be run as root. There is probably a problem with permissions of Skype files in BT2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •