Results 1 to 2 of 2

Thread: Not able to set the correct Regulatory Domain - Alfa AWUS036NHA

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Exclamation Not able to set the correct Regulatory Domain - Alfa AWUS036NHA

    Hi there,
    I would need help with changing my regulatory domain for my wireless Alfa (AWUS036NHA) card (AR9271 chipset).
    I haven't found any problems yet with the device except that I seem to not be able to change the regulatory domain for the card.

    I'm running BT5r3 gnome on a bootable USB drive (not persistent).

    I've seen the procedure work many times in videos etc..

    Code:
    ifconfig wlan1 down
    iw reg set [country code of your choice]
    ifconfig wlan1 up
    iw reg get (this should display your current country)
    If i monitor the kernel:
    Code:
    tail -f /var/log/messages
    ..and then plug in the wireless card this is what it says:

    Code:
    Jan 10 22:32:37 bt kernel: [16775.708148] usb 1-2: new high-speed USB device number 14 using ehci_hcd
    Jan 10 22:32:37 bt kernel: [16776.151244] usb 1-2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
    Jan 10 22:32:38 bt kernel: [16776.387358] ath9k_htc 1-2:1.0: ath9k_htc: HTC initialized with 33 credits
    Jan 10 22:32:38 bt kernel: [16776.597966] ath9k_htc 1-2:1.0: ath9k_htc: FW Version: 1.3
    Jan 10 22:32:38 bt kernel: [16776.599828] cfg80211: Calling CRDA for country: GB
    Jan 10 22:32:38 bt kernel: [16776.599892] ieee80211 phy12: Atheros AR9271 Rev:1
    Jan 10 22:32:38 bt kernel: [16776.602441] usb 1-2: ath9k_htc: USB layer initialized
    Jan 10 22:32:38 bt kernel: [16776.604389] cfg80211: Current regulatory domain intersected:
    Jan 10 22:32:38 bt kernel: [16776.604395] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    Jan 10 22:32:38 bt kernel: [16776.604405] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Then I type in (as expected):

    Code:
    iw reg set [any two digit country code]
    And the kernel does not respond at all.

    To check if it has changed:

    Code:
    iw reg get
    country 98:
            (2402 - 2482 @ 40), (N/A, 20)
    It does not matter if I bring the card down first and up afterwards it is still at GB.

    When I activate the card with (ifconfig wlan1 up) regardless if it's before or after I've issued (iw reg set [XX]) the kernel says this:

    Code:
    ADDRCONF(NETDEV_UP): wlan1: link is not ready
    (don't even know if that is helpful to know)

    Am I missing any kind of updates or files I would need or is the problem more complex?

    I'm a new user to both BT and linux but after many hours of searching I have to give up..

    Is it just some stupid thing that I've missed or what is it?
    If more info is needed just ask for it!

    Take the chance to be my hero of the day!

  2. #2
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Re: Not able to set the correct Regulatory Domain - Alfa AWUS036NHA

    Is this problem so trivial that I really should be able to solve it,
    does the post contain insufficient data or is the problem too complex to answer?

    Unfortunately I'm still unable to change it.. :/

Similar Threads

  1. ALFA AWUS036NHA Experience?
    By hitekhik in forum BackTrack 5 Beginners Section
    Replies: 11
    Last Post: 03-03-2013, 01:22 PM
  2. Alfa AWUS036NHA Problems
    By Ommmar1989 in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 12-30-2012, 04:55 PM
  3. How to create a domain user admin thru an exploited domain PC
    By SilicaG in forum BackTrack 5 General Topics
    Replies: 2
    Last Post: 07-03-2012, 01:35 AM
  4. WiFi regulatory domain
    By zburget in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 02-04-2012, 08:37 AM
  5. Replies: 1
    Last Post: 03-02-2010, 11:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •