Results 1 to 3 of 3

Thread: ALFA AWUS036H and internal Wifi-Adapter parallel using?!

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default ALFA AWUS036H and internal Wifi-Adapter parallel using?!

    Hi,
    first, I'm german but i hope i can express my problem good enough that you can help me.

    I have 2 W-Lan-Adapter:

    1. Internal Atheros Adapter of my Acer Aspire One D270
    2. Alfa AWUS036H with Realtek 8187 Chipset.

    All was fine, since i tried to install the newest Compat-Wireless-Driver, because the Alfa-Adapter won't connect
    to any AP's.. Wheter WEP neither WPA/2. After installing the Compat Driver (Version 3.8-rc2), ifconfig didn't showed
    any Wlan-Adapter anymore.. No wlan0, no wlan1, nothing!

    Now i don't know where's the problem?!

    The only thing i've noticed is the output of dmesg:

    rtl8187: ieee80211 alloc failed
    rtl8187: probe of 1-4:1.0 failed with error -12


    and after "modprobe ath9k"


    ath9k 0000:02:00.0: No memory for ieee80211_hw
    ath9k 0000:02:00.0: PCI INT A disable


    Hope you can understand my problem!

    Schrumpfi

  2. #2

    Default Re: ALFA AWUS036H and internal Wifi-Adapter parallel using?!

    Hi mate,

    To be honest your problem regarding the Alfa AWUS036H card seems to me a little odd. I'm using BT 5 since R1 and despite the one particular aspect about some specific Atheros driver the Alfa went smoothly anytime.

    I'm not sure if in this point there's something easy that can be done to restore your system in a right order.

    However, If I will be you I'll try to do the following:

    1. REINSTALL the BT r3. I really didn't got the point why you've compiled some drivers for Alfa as long the BTr3 contains exactly what you need.

    2. Try to connect using both wifi cards, one by at the time, to a wifi AP. Firstly try the most easy scenarios, no encryption. If both will work then upgrade the AP encryption to WEP and try again. And so on...I think you got the point, actually.

    If at some moment something goes wrong then at least you'll know exactly the hot point and eventually some logs as /var/log/messages and maybe others can be checked up for additional details.

    The easy step by step diagnostic will give more hints and knowledge than compiling drivers blindingly.

    Have fun..

  3. #3
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Re: ALFA AWUS036H and internal Wifi-Adapter parallel using?!

    Thanks for the hint!
    I looked for another way because it's much work to reinstall Backtrack.. :/
    After
    make uninstall
    The Compat-Driver both adapters have been detected and the Atheros is working perfectly! (Connecting to a WPA2-Networc)
    The injection of both adapters is working and airodump finds a lot of networcs with the ALFA!
    The only (big) problem now is, that the ALFA Adapter won't connect to any network?!
    No WPA WPA2 WEP or to a non encrypted network.. nothing.
    There is everytime "Validating Authentication" and at the end "Bad Password"
    I restarted the Pc and the rtl8187 driver, but no success..
    Any idea?

Similar Threads

  1. Replies: 0
    Last Post: 04-21-2011, 12:18 AM
  2. Replies: 1
    Last Post: 11-13-2009, 01:20 PM
  3. Internal somehow more sensitive than External Wifi adapter
    By valterra in forum OLD BackTrack 4 General Support
    Replies: 2
    Last Post: 07-25-2009, 12:09 PM
  4. best adapter for cracking wifi? AWUS036H?
    By dudeone in forum OLD Newbie Area
    Replies: 3
    Last Post: 07-19-2009, 03:14 PM
  5. Replies: 18
    Last Post: 04-22-2008, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •