Results 1 to 7 of 7

Thread: Airodump says: Error setting monitor mode when I can see it's set to Monitor mode...

  1. #1
    Just burned his ISO
    Join Date
    Oct 2007
    Posts
    14

    Default Airodump says: Error setting monitor mode when I can see it's set to Monitor mode...

    Hi

    I find Backtrack fascinating and am on my first attempt with cracking wep on my home network.

    I have found a guide which looks good:

    ryanunderdown com/2007/02/12/cracking-wep-using-backtrack

    and am on step 2: Collecting Data with Airodump and am having a prob.

    In the guide the guy said your card will probably show up as eth0

    Mine show's as: wlan with the following info:

    IEEE 802.11b Mode: Monitor (as I have kismet open), frquency 2.417 GHZ, access point not associated, bit rate: 11mb/s, retry: on, fragment thr: off, encryption key: off.

    In Airodump I type:

    airodump-ng wlan -w /mnt/hda1/home/mike/desktop 6 1

    it says:

    "1 is not a network interface" when in the guide is says typing 1 at the end is telling airodump to only collect IVS

    If I take the 1 away it says the same about 6 which the guide says is telling airodump the chanel of the target ap

    If I take 6 away it says:

    Error setting monitor mode on wlan

    As you can see in the info above my card is set to monitor due to having kismet running in the background...

    Any advice ?

    I know I need to sort out where the packets are going to be stored, /mnt/hda1/home/mike/desktop is just bs really but I assume wouldn't give that monitor mode error command.

    I'm gonna have to get a pen drive to store the IV's I think, as it says you can do that though it says the ntfs support allows allows windows partitions to be read as read only.

    Thanks in advance for your help !

    Regards,
    Mike

  2. #2
    Junior Member wvdmc's Avatar
    Join Date
    Jul 2007
    Posts
    32

    Default

    Your network interface should be the last parameter for airodump. And are you sure it's wlan and not wlan0 or something else?

    Put iwconfig into the bash and show us the output.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2007
    Posts
    6

    Default

    Type airodump-ng by itself to get its syntax. The interface is the last thing on the command line, after all the options.

    --Stryfe

  4. #4
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    change your tutorial .... it's crap....

    here we have wonderful video tutorials courtesy of mr -=Xploitz=-

    airodump-ng "iface name" -w "path to capture file" -c "channel" --bssid "access point mac" -a

    explications :

    "iface name" put here the name of your card (wlan0)

    -w "path to captur file", capture file to write, put the name you want ie "-w /root/test" will create /root/test-01.cap

    -c "channel" ,limit capture to this channel, put your victim chan here

    --bssid "accesspoint mac", limit the capture to this ap, put your victim ap mac

    -a will show only associated clients

    exemple : airodump-ng wlan0 -w /root/capture -c 1 --bssid 00:A1:34:56:12 -a
    will limit capture to the ap with mac 00:A1:34:56:12 on channel 1, the capture will be saved in /root/capture-01.cap, and will show only associated client in station list.....


    LIKE YOU SEE.....SEARCH HERE, FOLLOW THE GOOD GUIDES AND TRY, if you have errors, again search and try and if you still block on something, ask .... we will help you .....
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  5. #5
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    and for the order of commands ..... it's not important if you use aircrack-ng beta 1.0 wich was relized few days ago......

    but if you use normal aircrack-ng ..... put wlan0 at the end...
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  6. #6
    Just burned his ISO
    Join Date
    Oct 2007
    Posts
    6

    Default

    Quote Originally Posted by shamanvirtuel View Post
    and for the order of commands ..... it's not important if you use aircrack-ng beta 1.0 wich was relized few days ago......

    but if you use normal aircrack-ng ..... put wlan0 at the end...
    Phew... And here I thought I was a dumbass who got the syntax for airodump-ng messed up. lol

    --Stryfe

  7. #7
    Just burned his ISO
    Join Date
    Oct 2007
    Posts
    14

    Default

    Thanks so much for the replies guys, you're right shamanvirtuel that guide I was looking at was crap.

    I now have the correct line of code for airodump:

    airodump-ng wlan0 -w /root/capture -c 1 --bssid 00:A1:74:26:17 -a


    It still says: Error setting monitor mode on wlan0

    And I have kismet running, kismet says he has set the card in monitor mode ok and is able to look for networks.

    Could it be that my network card: Belkin 802.11b Wireless desk network card F5D6001 version 3001 is not supported ?

    Also, that crap guide I was looking at said that you need to either dual boot linux or use a pen drive to write the packets to, though I am able to open kwrite and save a document to the desktop of the BT interface, so does that mean I can save the packets to the desktop (or root) of the backtrack interface ? I assume it uses some ram to save the files to.

    Thanks !
    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •