Results 1 to 4 of 4

Thread: Trouble with wlan0 monitor mode

  1. #1
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Trouble with wlan0 monitor mode

    Okay so this is my first forum post, please bear with me.

    Specs:

    Pretty much brand new desktop PC running Windows 7

    Edimax 11N USB wireless LAN utility (EW-7717Un)

    BT5 R3 boot from a USB pen, although perhaps worth mentioning it will only work if I choose the no DRM option.

    On typing iwconfig, wlan0 does show up, but all the values provided are 'off', 'no' or '0'. The BT5 wireless manager is picking up nearby networks, however, leading me to believe this isn't a driver issue.

    Airmon-ng start wlan0 - nothing happens, it says 'interface, chipset' etc but no details below it.

    On typing airodump-ng wlan0 I get 'ARP Linktype set to 1, expected ARP<numbers>' .... 'ensure RFMON is enabled' ...

    I also tried airodump-ng mon0 - no such device.

    I acquired the BSSID of said network and tried pointing reaver to it with the command

    'reaver -i wlan0 -b xx:xx:xx:xx:xx:xx'

    Response was 'waiting for beacon from <bssid>' but nothing happens after this.

    I also tried 'sudo iwconfig wlan0 mode monitor' and got:

    'SET failed on device wlan0; invalid argument'.

    The signal strength of the required network is about 80%, and also worth mentioning I don't have an Internet connection at the moment, so any sys files or updates I need are being brought on 2nd USB pen/copied to the C drive so I can use the '1TB file system' to access it if required, although that hasn't proved much use.

    It's doing my head in. I just want to get on this network.

    Any help much appreciated,

    Yours,

    JustSomeGuy

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Trouble with wlan0 monitor mode

    When you try to set any value with iwconfig, you first have to bring down the interface wit ifconfig: ifconfig wlan0 down

    Then iwconfig wlan0 mode monitor and then ifconfig wlan0 up

    Then see if iface is in monitor mode: iwconfig wlan0

    Please, you did not submit the sensible info: CHIPSET...It should be rt2770 or rt2870...

    Luck..
    Last edited by maverik35; 01-08-2013 at 09:58 AM.

  3. #3
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    2

    Default Re: Trouble with wlan0 monitor mode

    Quote Originally Posted by maverik35 View Post
    When you try to set any value with iwconfig, you first have to bring down the interface wit ifconfig: ifconfig wlan0 down

    Then iwconfig wlan0 mode monitor and then ifconfig wlan0 up

    Then see if iface is in monitor mode: iwconkfig wlan0

    Please, you did not submit the sensible info: CHIPSET...It should be rt2770 or rt2870...

    Luck..
    Ive tried bringing the interface down, changing it to monitor mode, then putting it back up. Ive also tried physically removing the adapter in between doing this.

    did you mean to type "iwconkfig wlan0" or did you mean "iwconfig wlan0"? i might be missing a trick,

    Also, i did realise after i posted this that i shouldve posted the chipset - first off, its actually an Edimax EW-7622UMN , and so the chipset is a Realtek RTL8192SU .

    i just read this http://www.backtrack-linux.org/forum...ad.php?t=49795

    and now thinking that maybe its an adapter issue and im going to have to get a brand new one?

    Any help is appreciated, guys and girls. Thank you.

    JSG

  4. #4
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Trouble with wlan0 monitor mode

    Sorry is iwconfig, I modified the post.

    As to the chipset, you posted you had a Edimax 11N USB wireless LAN utility (EW-7717Un). But now you say it is a Edimax EW-7622UMN..

    Well, with chipset Realtek RTL8192SU, there is one driver but in beta stage, read here: http://linuxwireless.org/en/users/Drivers/rtl819x or you could go to the vendors page and see if there is one driver from them.

    As to buy a new one, if you are newbbie and do not want to get in so many issues as to compiling, work-around solutions, etc, I recommend you:
    The Alfa 500, Alfa 1 or the Alfa AW36NH (read this post about Alfa AW36NH: http://www.backtrack-linux.org/forum...ight=awus036nh).

    Luck.
    Last edited by maverik35; 01-08-2013 at 10:29 AM.

Similar Threads

  1. Wireshark & Monitor Mode (AWUS036H) trouble
    By borcak in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 09-17-2011, 01:59 AM
  2. Problem wlan0 rtl819xSE monitor mode
    By Nytro in forum Beginners Forum
    Replies: 0
    Last Post: 12-21-2010, 07:37 PM
  3. error setting monitor mode on wlan0
    By kikoman in forum OLD Newbie Area
    Replies: 3
    Last Post: 10-09-2007, 04:53 PM
  4. Replies: 6
    Last Post: 10-09-2007, 12:31 PM
  5. Error setting monitor mode on wlan0
    By Kwinz in forum OLD Newbie Area
    Replies: 10
    Last Post: 05-27-2007, 06:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •