Results 1 to 6 of 6

Thread: Dual Boot help

  1. #1
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    10

    Default Dual Boot help

    Hi i have BT and XP dual booting ok but I only have 2 seconds to decide which one I boot into and bt is the default. I would like to have XP as the default and have read I have to add default=windows. here is my config file....

    boot = /dev/sda
    prompt
    timeout=1200
    bitmap=/boot/splash.bmp
    change-rules
    reset
    vga = 0x317

    image = /boot/vmlinuz
    root = Current
    initrd = /boot/splash.initrd
    label = Backtrack
    read-only

    default=Windows
    other=/dev/sda1
    label=Windows
    table=/dev/sda


    After I added default=Windows I read I have to type lilo into console to write changes. When I do this I get Fatal: open /boot/splash.bmp: No such file or directory.

  2. #2
    Member imported_rokrmc's Avatar
    Join Date
    Aug 2007
    Posts
    155

    Default

    Quote Originally Posted by jay2005 View Post
    Hi i have BT and XP dual booting ok but I only have 2 seconds to decide which one I boot into and bt is the default. I would like to have XP as the default and have read I have to add default=windows. here is my config file....

    boot = /dev/sda
    prompt
    timeout=1200
    bitmap=/boot/splash.bmp
    change-rules
    reset
    vga = 0x317

    image = /boot/vmlinuz
    root = Current
    initrd = /boot/splash.initrd
    label = Backtrack
    read-only

    default=Windows
    other=/dev/sda1
    label=Windows
    table=/dev/sda


    After I added default=Windows I read I have to type lilo into console to write changes. When I do this I get Fatal: open /boot/splash.bmp: No such file or directory.
    I make it like this and its works

    boot = /dev/sda
    prompt
    timeout = 1200
    bitmap=/boot/splash.bmp
    change-rules
    reset
    vga = 0x317
    #Linux
    image = /boot/vmlinuz
    root = current
    initrd = /boot/splash.initrd
    label = Linux

    #windows
    other=/dev/sda1
    label = winxp
    table = /dev/sda

  3. #3
    Member hawaii67's Avatar
    Join Date
    Feb 2006
    Posts
    318

    Default

    I use grub
    Don't eat yellow snow :rolleyes:

  4. #4
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    lilo -v is the ececution command. your lilo config is fine 1200 is two minutes so the problem is you have not excecuted

  5. #5
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    10

    Default

    Thanks for replies guys but it still aint working. I followed a guide to get dual boot working in the first place but cant find it now. Here is what I am doing.
    I am typing nano /etc/lilo.conf and I get

    boot = /dev/sda
    prompt
    timeout=1200
    bitmap=/boot/splash.bmp
    change-rules
    reset
    vga = 0x317

    image = /boot/vmlinuz
    root = Current
    initrd = /boot/splash.initrd
    label = Backtrack
    read-only

    default=Windows
    other=/dev/sda1
    label=Windows
    table=/dev/sda

    It looks ok but when I boot my laptop I get options of windows or bt.
    As you can see in my config file the label is set to Backtrack (the option i have is bt). so i must have edited some other file. Is there any other file that affects the boot process as I cant remember how I got it dualbooting in the first place. This is why when I edit the lilo.conf and make changes nothing happens. Thanks in advance

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    research the chroot command

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •