Results 1 to 6 of 6

Thread: SSH Server issue

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    7

    Question SSH Server issue

    I have a SSH server hosted on my desktop in BackTrack 5 r3 64-bit. I m able to access the ssh sever from the LAN using my laptop but when I try to access my ssh server from my office using the public IP it doesn't work. The connection just pauses with no response.

    Command: ssh -v xxx.xxx.xxx.xxx -p22

    What all I have tried so far:
    1. Port forwarding in the router for Port 22.
    2. Allowed port 22 in iptables.
    3. Nmap result on private ip shows port 22 open and for public ip it says port 22 filtered.
    4. ssh-keygen to generate the keys. I had also used sshd-generate before but now when I try to do sshd-generate I get "sshd-generate: command not found"

    If I stop the sshd and open netcat using "netcat -lvp 22" then using "http://www.ping.eu/port-chk/" to check the status of port 22 I get the incoming packet detail in netcat output. But when i start sshd on port 22 and try to login using public ip from my office computer I cannot connect to my ssh server computer.
    Keeping the sshd service running and then trying to check for port 22 status using the above mentioned website I get port open. But still I cannot connect to the ssh sever using my public IP.

  2. #2
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: SSH Server issue

    Quote Originally Posted by KnightCrawler View Post
    I have a SSH server hosted on my desktop in BackTrack 5 r3 64-bit. I m able to access the ssh sever from the LAN using my laptop but when I try to access my ssh server from my office using the public IP it doesn't work. The connection just pauses with no response.

    Command: ssh -v xxx.xxx.xxx.xxx -p22

    What all I have tried so far:
    1. Port forwarding in the router for Port 22.
    2. Allowed port 22 in iptables.
    3. Nmap result on private ip shows port 22 open and for public ip it says port 22 filtered.
    4. ssh-keygen to generate the keys. I had also used sshd-generate before but now when I try to do sshd-generate I get "sshd-generate: command not found"

    If I stop the sshd and open netcat using "netcat -lvp 22" then using "http://www.ping.eu/port-chk/" to check the status of port 22 I get the incoming packet detail in netcat output. But when i start sshd on port 22 and try to login using public ip from my office computer I cannot connect to my ssh server computer.
    Keeping the sshd service running and then trying to check for port 22 status using the above mentioned website I get port open. But still I cannot connect to the ssh sever using my public IP.
    hi
    if you can help:
    I did a test between my "ssh-server-BT5-r3_32bit_VM" && my "" ssh-client-smartphone "
    -server connect to my home-router with eth0 (ext-IP: 74.4x.xxx.xxx) [adsl provider-A]
    client-connect with 3G (ext-IP: 37.2x.xxx.xxx) [adsl-provider B]
    -distance 14 km
    my steps:
    SERVER BT5-r3:
    # sshd-generated
    # application> backtrack> service> sshd start
    # Port forward my router port 22 to my BT5-r3-VM (192.168.1.7)
    CLIENT smartphone (Android):
    # download & open ConnectBot (free-app for ssh-client)
    # connect root@74.4x.xxx.xxx ........
    enter password: toor ............
    when the connection is established is our beloved root-shell

    I "played for about 40 minutes without losing the connection"

    screenshot:
    http://imageshack.us/photo/my-images/713/ssh1w.png/
    http://imageshack.us/photo/my-images/198/ssh2.png/
    http://imageshack.us/photo/my-images/856/ssh3.png/

    I hope that this example maybe you can help

    bye & marry christmas!

  3. #3
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    7

    Default Re: SSH Server issue

    Quote Originally Posted by zimmaro View Post
    hi
    if you can help:
    I did a test between my "ssh-server-BT5-r3_32bit_VM" && my "" ssh-client-smartphone "
    -server connect to my home-router with eth0 (ext-IP: 74.4x.xxx.xxx) [adsl provider-A]
    client-connect with 3G (ext-IP: 37.2x.xxx.xxx) [adsl-provider B]
    -distance 14 km
    my steps:
    SERVER BT5-r3:
    # sshd-generated
    # application> backtrack> service> sshd start
    # Port forward my router port 22 to my BT5-r3-VM (192.168.1.7)
    CLIENT smartphone (Android):
    # download & open ConnectBot (free-app for ssh-client)
    # connect root@74.4x.xxx.xxx ........
    enter password: toor ............
    when the connection is established is our beloved root-shell

    I "played for about 40 minutes without losing the connection"

    screenshot:
    http://imageshack.us/photo/my-images/713/ssh1w.png/
    http://imageshack.us/photo/my-images/198/ssh2.png/
    http://imageshack.us/photo/my-images/856/ssh3.png/

    I hope that this example maybe you can help

    bye & marry christmas!
    I tried the same but it's not working for me.

  4. #4
    Just burned their ISO webninja's Avatar
    Join Date
    Dec 2007
    Posts
    15

    Default Re: SSH Server issue

    what does your /var/log/auth.log show when you attempt to login to SSH from public IP?

  5. #5
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    7

    Default Re: SSH Server issue

    Quote Originally Posted by webninja View Post
    what does your /var/log/auth.log show when you attempt to login to SSH from public IP?
    Dec 20 23:58:27 bt sshd[7232]: Failed password for root from xxx.xxx.xxx.xxx port 57023 ssh2
    Dec 20 23:58:30 bt sshd[7241]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=xxx.xxx.xxx.xxx user=root
    Dec 20 23:58:30 bt sshd[7241]: pam_winbind(sshd:auth): getting password (0x00000388)
    Dec 20 23:58:30 bt sshd[7241]: pam_winbind(sshd:auth): pam_get_item returned a password
    Dec 20 23:58:30 bt sshd[7241]: pam_winbind(sshd:auth): request wbcLogonUser failed: WBC_ERR_AUTH_ERROR, PAM error: PAM_USER_UNKNOWN (10), NTSTATUS: NT_STATUS_NO_SUCH_USER, Error message was: No such user


    But I m using the correct username and password for sure.

  6. #6
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    7

    Default Re: SSH Server issue

    Thank you everyone. The problem is solved now. The problem was with my office computer some issue on the office's network side. It worked flawlessly when I tried connecting from my friend's computer.
    I should have figured it out when "www.ping.eu/port-chk" said that the port is open.

Similar Threads

  1. VNC Server Connection Issue
    By Sesam3 in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 01-19-2013, 04:50 PM
  2. BT5 R2 KDE 32bit + DHCP3 server issue
    By Sil3nc3r in forum BackTrack 5 Fixes
    Replies: 4
    Last Post: 05-24-2012, 01:55 AM
  3. Replies: 2
    Last Post: 11-30-2010, 11:55 PM
  4. VNC server issue
    By maximus57 in forum Beginners Forum
    Replies: 5
    Last Post: 11-27-2010, 03:57 AM
  5. Backtrack 4 Final - Vmware Tools - X Server Issue the xth
    By sp1r1te in forum Beginners Forum
    Replies: 2
    Last Post: 07-01-2010, 12:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •