I recently did an update, I'm running backtrack 5 r3, the update is listed below after I did this update Desktop Effects were broken could someone please point out what part of the update broke desktop effects.

Note that I can still run Xrender compositing but not OpenGL compositing as KDE gives the excuse that it was disabled by another application and reverts back to Xrender each time I select OpenGL.

I would be ok with this except for Xrender is slower that OpenGL. Listed below are the files that were updated.


Installed: icedtea-netx
Updated: dpkg, mysql-common, mysql-server, libc-bin, libc6, libc-bin, libc6-i686, libc-dev-bin, libc6-dev, tzdata-java, tzdata, libmysqlclient16, mysql-client-core-5.1, mysql-client-5.1, lsb-base, mysql-server-core-5.1, mysql-common, mysql-server-5.1, apt, libc-bin, python2.6-dev, libpython2.6, python2.6, python2.6-minimal, apt-utils, cron, dhcp3-client, dhcp3-common, gpgv, gnupg, vim-tiny, vim, vim-runtime, vim-common, procps, libkrb5-dev, krb5-multidev, libk5crypto3, libgssapi-krb5-2, libkrb5-3, libkrb5support0, libgssrpc4, libkdb5-4, libkadm5srv-mit7, libkadm5clnt-mit7, libxml2-dev, libxml2, bind9-host, dnsutils, libisc60, libdns64, libisccc60, libisccfg60, liblwres60, libbind9-60, libgc1c2, libgnutls-dev, libgnutls26, libgssglue1, apache2, apache2-mpm-prefork, apache2.2-common, apache2.2-bin, apache2-utils, apt-transport-https, libdbus-1-3, libexpat1-dev, libexpat1, dbus, dbus-x11, dpkg-dev, expat, libglib2.0-0, libnss3-1d, flashplugin-installer, libtiff4-dev, libtiffxx0c2, libtiff4, ghostscript, libgs8, gnupg-curl, libmagickcore2, libmagickwand2, imagemagick, initramfs-tools, initramfs-tools-bin, ruby1.8-dev, libruby1.8, ruby1.8, libreadline-ruby1.8, irb1.8, lsb-release, landscape-common, php5-cli, php5-sqlite, php5-mysql, libpq5, php5-pgsql, libapache2-mod-php5, php5-common, libexif12, libgl1-mesa-dev, mesa-common-dev, libgl1-mesa-dri, libgl1-mesa-glx, libglu1-mesa-dev, libglu1-mesa, libmagickcore2-extra, libopenssl-ruby1.8, libproxy0, libssh-4, libxml2-utils, libxslt1-dev, libxslt1.1, icedtea-6-jre-cacao, openjdk-6-jre-headless, openjdk-6-jre-lib, openjdk-6-jre, openjdk-6-jdk, php5, python-distutils-extra, python-libxml2, unattended-upgrades, python-software-properties, python3.1, python3.1-minimal, ri1.8, rdoc1.8, software-properties-kde, sudo, xsltproc