i was trying to upgrade from r2 to r3, and that's what i've got:

Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package jigsaw is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package libcrafter
E: Unable to locate package blueranger
E: Unable to locate package dbd
E: Unable to locate package inundator
E: Unable to locate package intersect
E: Unable to locate package mercury
E: Unable to locate package trixd00r
E: Unable to locate package netgear-telnetenable
E: Unable to locate package jboss-autopwn
E: Unable to locate package deblaze
E: Unable to locate package sakis3g
E: Unable to locate package voiphoney
E: Unable to locate package apache-users
E: Unable to locate package phrasendrescher
E: Unable to locate package kautilya
E: Unable to locate package manglefizz
E: Unable to locate package rainbowcrack
E: Unable to locate package rainbowcrack-mt
E: Unable to locate package lynis-audit
E: Unable to locate package spooftooph
E: Unable to locate package wifihoney
E: Unable to locate package twofi
E: Unable to locate package truecrack
E: Unable to locate package acccheck
E: Unable to locate package statsprocessor
E: Unable to locate package iphoneanalyzer
E: Unable to locate package jad
E: Unable to locate package javasnoop
E: Unable to locate package mitmproxy
E: Unable to locate package ewizard
E: Unable to locate package multimac
E: Unable to locate package smbexec
E: Unable to locate package websploit
E: Unable to locate package dnmap
E: Unable to locate package johnny
E: Unable to locate package unix-privesc-check
E: Unable to locate package sslcaudit
E: Unable to locate package dhcpig
E: Unable to locate package intercepter-ng
E: Unable to locate package u3-pwn
E: Unable to locate package binwalk
E: Unable to locate package laudanum
E: Unable to locate package wifite
E: Unable to locate package tnscmd10g
E: Unable to locate package bluepot
E: Unable to locate package dotdotpwn
E: Unable to locate package subterfuge
E: Package 'jigsaw' has no installation candidate
E: Unable to locate package urlcrazy
E: Unable to locate package creddump
E: Unable to locate package android-sdk
E: Unable to locate package apktool
E: Unable to locate package ded
E: Unable to locate package dex2jar
E: Unable to locate package droidbox
E: Unable to locate package smali
E: Unable to locate package termineter
E: Unable to locate package multiforcer
E: Unable to locate package bbqsql
E: Unable to locate package htexploit
E: Unable to locate package smartphone-pentest-framework
E: Unable to locate package fern-wifi-cracker
E: Unable to locate package powersploit
E: Unable to locate package webhandler